summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2021-09-29 17:33:23 +0300
committerYigit Sever2021-09-29 17:33:23 +0300
commitab5a1b4615b6a2d13e88528e3205e8c3bb735d52 (patch)
tree79769b0c7f6f520fb4860f14839ec04a2dfd7829
parent6424b7bca9e136cb4480c2be71cd22fbcb0ac43e (diff)
downloadaur-ab5a1b4615b6a2d13e88528e3205e8c3bb735d52.tar.gz
Add plugin dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 812d8861b1bc..83b6a6379ca8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = gourmand
- pkgdesc = A recipe manager for desktop with the possibilities to import, organize, and tweak recipes
+ pkgdesc = A recipe manager for desktop that can import recipes
pkgver = 1.0.0
pkgrel = 1
url = https://github.com/GourmandRecipeManager/gourmand
@@ -12,8 +12,16 @@ pkgbase = gourmand
depends = gst-python
depends = python-pillow
depends = python-sqlalchemy
+ depends = python-lxml
+ depends = python-cairo
+ depends = python-requests
optdepends = python-beautifulsoup4: Webpage import plugin
- provides = gourmand
+ optdepends = python-scrape-schema-recipe: Webpage import plugin
+ optdepends = python-selenium
+ optdepends = python-keyring
+ optdepends = python-ebooklib: EPub export plugin
+ optdepends = python-reportlab: Printing & PDF export plugin
+ optdepends = python-gtkspellcheck: Spell checking plugin
conflicts = gourmet
source = gourmand-1.0.0-py3-none-any.whl::https://github.com/GourmandRecipeManager/gourmand/releases/download/1.0.0/gourmand-1.0.0-py3-none-any.whl
sha256sums = 9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4
diff --git a/PKGBUILD b/PKGBUILD
index cf54749397bd..8059a000fe30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,18 @@ pkgdesc="A recipe manager for desktop that can import recipes"
arch=('any')
url="https://github.com/GourmandRecipeManager/gourmand"
license=('GPL')
-depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy')
+depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests')
makedepends=('python-pip')
checkdepends=()
-optdepends=('python-beautifulsoup4: Webpage import plugin')
+optdepends=(
+ 'python-beautifulsoup4: Webpage import plugin'
+ 'python-scrape-schema-recipe: Webpage import plugin'
+ 'python-selenium'
+ 'python-keyring'
+ 'python-ebooklib: EPub export plugin'
+ 'python-reportlab: Printing & PDF export plugin'
+ 'python-gtkspellcheck: Spell checking plugin'
+ )
conflicts=('gourmet')
source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')