summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValère Monseur2022-12-16 23:32:35 +0100
committerValère Monseur2022-12-16 23:32:35 +0100
commitab5b8b6b187bd11bbfdc5a47bcbe2ff0edf99c47 (patch)
tree7e084e1ebc548da272d9908f382a34f3fd2a1a55
parent8cb2215f3a1986c370742bfd581cfa7ebc9ce0cf (diff)
downloadaur-ab5b8b6b187bd11bbfdc5a47bcbe2ff0edf99c47.tar.gz
upgrade to 3.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--info2src.pl.patch53
3 files changed, 69 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 781a1763bbfd..949c73bbb0fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ne
pkgdesc = The nice editor, a fast small powerful and simple to use editor
- pkgver = 3.3.1
+ pkgver = 3.3.2
pkgrel = 1
url = http://ne.di.unimi.it
arch = i686
@@ -8,7 +8,9 @@ pkgbase = ne
license = GPL3
depends = ncurses
depends = texinfo
- source = https://github.com/vigna/ne/archive/3.3.1.tar.gz
- sha512sums = 4adce440c1d941e51cc688ab55f215013c30366e555dfe67f62494ade5ccf90ef4e3062b4bff023f3dcc8dda7f2bd89ad3f62632d51393d154b197eaf4856297
+ source = https://github.com/vigna/ne/archive/3.3.2.tar.gz
+ source = info2src.pl.patch
+ sha512sums = 591be3eb44419ce5fec8c2a02c06aab95dc7d04aa8eb191219588af1b8851ae86e11b8eace25fa970817ac6451c991354e8c20d591dd4fb45114e1cdb6dd1ec6
+ sha512sums = 0c95be21e40572d3feb5db4e73fea67616a5a8b8d4570511bc9267b0ed59c75b2169881faa23adcec8e4f16ea771ba28c12f90b2876672bda3d39796d894a089
pkgname = ne
diff --git a/PKGBUILD b/PKGBUILD
index fdc18613f16d..457ffddd4bde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,26 @@
# Contributor: Ben <ben@benmazer.net>
pkgname=ne
-pkgver=3.3.1
+pkgver=3.3.2
pkgrel=1
pkgdesc='The nice editor, a fast small powerful and simple to use editor'
arch=(i686 x86_64)
url='http://ne.di.unimi.it'
license=(GPL3)
depends=(ncurses texinfo)
-source=("https://github.com/vigna/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('4adce440c1d941e51cc688ab55f215013c30366e555dfe67f62494ade5ccf90ef4e3062b4bff023f3dcc8dda7f2bd89ad3f62632d51393d154b197eaf4856297')
+source=("https://github.com/vigna/${pkgname}/archive/${pkgver}.tar.gz"
+ "info2src.pl.patch")
+sha512sums=('591be3eb44419ce5fec8c2a02c06aab95dc7d04aa8eb191219588af1b8851ae86e11b8eace25fa970817ac6451c991354e8c20d591dd4fb45114e1cdb6dd1ec6'
+ '0c95be21e40572d3feb5db4e73fea67616a5a8b8d4570511bc9267b0ed59c75b2169881faa23adcec8e4f16ea771ba28c12f90b2876672bda3d39796d894a089')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i "${srcdir}"/info2src.pl.patch
+}
build() {
cd ${pkgname}-${pkgver}
- make PREFIX=/usr LIBS="-lcurses -ltinfo"
+ make -j1 PREFIX=/usr LIBS="-lcurses -ltinfo"
}
package() {
diff --git a/info2src.pl.patch b/info2src.pl.patch
new file mode 100644
index 000000000000..128ffd6b69d0
--- /dev/null
+++ b/info2src.pl.patch
@@ -0,0 +1,53 @@
+From 90ae494711a06944f0027224cf6a4b4a812d1e95 Mon Sep 17 00:00:00 2001
+From: Todd Lewis <utoddl@gmail.com>
+Date: Fri, 16 Dec 2022 16:33:40 -0500
+Subject: [PATCH] pick smarter quotes if possible; support texinfo 7.0+
+
+---
+ src/info2src.pl | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/src/info2src.pl b/src/info2src.pl
+index 53935c0..56d4964 100755
+--- a/src/info2src.pl
++++ b/src/info2src.pl
+@@ -1,6 +1,8 @@
+ #!/usr/bin/env perl
+
+ use strict;
++use utf8;
++use open ':std', ':encoding(UTF-8)';
+ $| = 1;
+
+ # Todd M. Lewis <utoddl@gmail.com>
+@@ -65,7 +67,11 @@
+ my @line = <INFO>;
+ close INFO;
+ my $line = join '', @line;
+- $line =~ s<\*note *(\s*)(.+?)::> <$1`$2'>gis;
++
++ # Pick left- and right-quote depending on whether our docs contain u+2018 and u+2019 already.
++ my ($lq, $rq) = ($line =~ m/‘.+?’/) ? ('‘', '’') : ("'", "'");
++
++ $line =~ s<\*note *(\s*)(.+?)::> <$1$lq$2$rq>gis;
+
+ my $state = 'searching';
+ my $command;
+@@ -74,7 +80,7 @@
+ chomp;
+ if ( $state eq 'searching' )
+ {
+- next unless ( m/^(Syntax: )['`](([^ ]+).*)'\s*$/ );
++ next unless ( m/^(Syntax: )[‘'`](([^ ]+).*)[’']\s*$/ );
+ $command = uc $3;
+ $commands{$command}->{"cmd"} = "$3";
+ $commands{$command}->{"text"}[0] = "$1$2";
+@@ -93,7 +99,7 @@
+
+ # print "---2 read \"$_\"\n";
+
+- if ( m/^(Abbreviation: )['`](.+)'/ )
++ if ( m/^(Abbreviation: )[‘'`](.+)[’']/ )
+ {
+ $commands{$command}->{"abbr"} = "$2";
+ push @{$commands{$command}->{"text"}}, "$1$2";