summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseiuneko2021-12-07 15:12:17 +0800
committerseiuneko2021-12-07 15:12:17 +0800
commitab5d125e112735d860e972e3d9fb61e67394ccbc (patch)
treee5d1d667b0a7b1c86b1f8e28c1cb5a62d0328e7f
parent151c48d3a503843844e5a3c983809936336ba4ad (diff)
downloadaur-ab5d125e112735d860e972e3d9fb61e67394ccbc.tar.gz
add novnc.service by @yjun and add inetutils dependences
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--novnc.service13
3 files changed, 31 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e93517d7db82..017a27e4467c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = novnc-git
pkgdesc = HTML VNC Client Library and Application
- pkgver = 1.2.0.r20.g90456db
+ pkgver = 1.3.0.r28.g78eda3c
pkgrel = 1
- url = https://github.com/kanaka/noVNC
+ url = https://github.com/novnc/noVNC
arch = any
license = custom
makedepends = git
depends = bash
depends = websockify
+ depends = inetutils
optdepends = python-numpy: better HyBi protocol performance
provides = novnc
conflicts = novnc
source = novnc::git+https://github.com/novnc/noVNC.git
- md5sums = SKIP
+ source = novnc.service
+ sha512sums = SKIP
+ sha512sums = 5dce6fb71dcdeab9ebe3986ebad431d01bb01860cb9960b1e70af84b2beba2330738cd9aa37ab9e025ee8263cba7475d484d5c6d55d4b3750d27aff37c7aef41
pkgname = novnc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 861e6ad58be4..2a2fc4e1a8ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
# Contributor: Radek Podgorny <radek@podgorny.cz>
pkgname=novnc-git
-pkgver=1.2.0.r20.g90456db
+pkgver=1.3.0.r28.g78eda3c
pkgrel=1
pkgdesc="HTML VNC Client Library and Application"
arch=(any)
-url="https://github.com/kanaka/noVNC"
+url="https://github.com/novnc/noVNC"
license=('custom')
-depends=('bash' 'websockify')
+depends=('bash' 'websockify' 'inetutils')
optdepends=('python-numpy: better HyBi protocol performance')
provides=('novnc')
conflicts=('novnc')
-source=("novnc::git+https://github.com/novnc/noVNC.git")
-md5sums=('SKIP')
+source=("novnc::git+https://github.com/novnc/noVNC.git"
+ "novnc.service")
+sha512sums=('SKIP'
+ '5dce6fb71dcdeab9ebe3986ebad431d01bb01860cb9960b1e70af84b2beba2330738cd9aa37ab9e025ee8263cba7475d484d5c6d55d4b3750d27aff37c7aef41')
makedepends=("git")
pkgver() {
- cd "$srcdir"/novnc
+ cd "$srcdir"/novnc
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -26,10 +28,12 @@ prepare(){
sed \
-e 's#\(share\)#\1/webapps#g' \
-e '2 i WEBSOCKIFY=/usr/bin/websockify' \
- -i utils/launch.sh
+ -i utils/novnc_proxy
}
package() {
+ install -Dm644 novnc.service "${pkgdir}/usr/lib/systemd/system/novnc.service"
+
cd "novnc"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -39,7 +43,7 @@ package() {
install -dm644 "$pkgdir/usr/share/doc/$pkgname"
( cd docs; find . ! -name 'LICENSE*' -type f -exec cp -a {} "$pkgdir/usr/share/doc/$pkgname/{}" \; )
- install -Dm755 utils/launch.sh "$pkgdir/usr/bin/novnc"
+ install -Dm755 utils/novnc_proxy "$pkgdir/usr/bin/novnc"
install -dm755 "$pkgdir/usr/share/webapps/novnc"
cp -a app core po vendor vnc.html karma.conf.js package.json vnc_lite.html "$pkgdir/usr/share/webapps/novnc"
diff --git a/novnc.service b/novnc.service
new file mode 100644
index 000000000000..039d7a886331
--- /dev/null
+++ b/novnc.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=noVNC Service
+After=network.target
+
+[Service]
+Type=idle
+DynamicUser=yes
+Restart=on-failure
+RestartSec=5s
+ExecStart=/usr/bin/novnc --vnc %i
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file