summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRains2017-05-01 12:46:18 +0800
committerRains2017-05-01 12:52:56 +0800
commitab8371d50cc783443b0aa773ef84a5986437c629 (patch)
tree8256e4a59ec1497c3f54b626712ab677df3cf20a
parent9bbd56d34911bdb80a591eec6d007071f0656ac9 (diff)
downloadaur-ab8371d50cc783443b0aa773ef84a5986437c629.tar.gz
fix pkgver function
-rw-r--r--PKGBUILD6
-rw-r--r--cloud9.install14
2 files changed, 4 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1802424ced8..93fe9811ef24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=c9.core
_pkgname=core
-pkgver=3.0
+pkgver=3.0.4edb9102
pkgrel=1
pkgdesc="Cloud9 Core - Part of the Cloud9 SDK for Plugin Development https://c9.io"
url="http://c9.io/"
@@ -26,12 +26,12 @@ md5sums=('SKIP'
'fad2be0e1cf10d29ad98727739353626'
'373c0a4e2b8278fd315940dd61b3a952'
'8fbf927e0cb9af22bf15666fd993a5e1'
- '67158ed4cec5bd4d7298890d57a214f4'
+ 'e5bd6988f4d1e76dd999c6478115af8d'
)
pkgver() {
cd "$pkgname"
- git describe | sed 's/^v//;s/-/./g' || echo $pkgver
+ echo 3.0.$(git rev-parse --short HEAD)
}
build() {
diff --git a/cloud9.install b/cloud9.install
index 57ac0e03fd13..04776bdbe944 100644
--- a/cloud9.install
+++ b/cloud9.install
@@ -26,7 +26,7 @@ post_upgrade() {
echo "Stop all processes running under the cloud9 user and reinstall cloud9"
echo "or change the uid manually. (usermod -u 419 cloud9)"
fi
- chown -R cloud9:cloud9 /opt/cloud9
+ chown -R 419:419 /opt/cloud9
fi
}
@@ -35,15 +35,3 @@ post_remove() {
getent group cloud9 > /dev/null 2>&1 && groupdel cloud9
}
-
-
-
-function post_install {
- echo "Notes:"
- echo "------"
- echo "* The default workspace is the working directory."
- echo "* Call 'cloud9 -w <workspace>' to switch to a different workspace."
- echo "* To listen on a different port you can use the '-p' switch."
- echo "* See 'cloud9 --help' for more information."
-}
-