summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2023-01-07 22:55:54 +0600
committerMubashshir2023-01-07 23:47:05 +0600
commitab97ca76b6652066cc75d6a25e60a6df2e5b7995 (patch)
tree01d6f35eda297f75a64abb9570cb3667d7bd0024
parent2e506bc5eb356cde5d91bb4e514e7f2323e35b9f (diff)
downloadaur-ab97ca76b6652066cc75d6a25e60a6df2e5b7995.tar.gz
lib32-gst-bad-ugly: Fix conflicts
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--0001-Allow-disabling-gstreamer.patch (renamed from 0000-Allow-disabling-gstreamer.patch)0
-rw-r--r--0001-meson-Allow-building-with-system-orc.patch28
-rw-r--r--PKGBUILD37
5 files changed, 31 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 721ed530fa1e..1617fda958a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gst-bad-ugly
pkgdesc = Multimedia graph framework (32-bit)
pkgver = 1.20.5
- pkgrel = 1
+ pkgrel = 2
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -67,14 +67,12 @@ pkgbase = lib32-gst-bad-ugly
makedepends = lib32-ffmpeg
options = !debug
source = git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git#tag=1.20.5
- source = 0000-Allow-disabling-gstreamer.patch
- source = 0001-meson-Allow-building-with-system-orc.patch
+ source = 0001-Allow-disabling-gstreamer.patch
source = 0002-HACK-meson-Disable-broken-tests.patch
source = 0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
validpgpkeys = D637032E45B8C6585B9456565D2EEE6F6F349D7C
sha256sums = SKIP
sha256sums = 79b4d76bdb1ccf05099eff677d72cdf9df50788261891be41065aca21b4ea8b6
- sha256sums = 292edebc224557db08404b0d53e2824413f0aad2a99c991de2cb8ccc6e9a7683
sha256sums = 11971a978e37fda3822f95fb61b59ba3ded6487066dc59fcbde7b72a3a9cfe70
sha256sums = 79d3038a0ba0c3958ffa8b5aec8431336b372906c07c0c878c3767bec0acb46f
@@ -84,6 +82,7 @@ pkgname = lib32-gst-libav-latest
depends = lib32-ffmpeg
provides = lib32-gst-ffmpeg=1.20.5
provides = lib32-gst-libav=1.20.5
+ conflicts = lib32-gst-libav
pkgname = lib32-gst-plugins-ugly-latest
pkgdesc = Multimedia graph framework (32-bit) - ugly plugins
@@ -96,6 +95,7 @@ pkgname = lib32-gst-plugins-ugly-latest
depends = lib32-x264
depends = lib32-opencore-amr
provides = lib32-gst-plugins-ugly=1.20.5
+ conflicts = lib32-gst-plugins-ugly
pkgname = lib32-gst-plugins-bad-libs-latest
pkgdesc = Multimedia graph framework (32-bit) - bad
@@ -108,6 +108,7 @@ pkgname = lib32-gst-plugins-bad-libs-latest
depends = lib32-libgudev
depends = lib32-libusb
provides = lib32-gst-plugins-bad-libs=1.20.5
+ conflicts = lib32-gst-plugins-bad-libs
pkgname = lib32-gst-plugins-bad-latest
pkgdesc = Multimedia graph framework (32-bit) - bad plugins
@@ -165,3 +166,4 @@ pkgname = lib32-gst-plugins-bad-latest
depends = lib32-x265
depends = lib32-zbar
provides = lib32-gst-plugins-bad=1.20.5
+ conflicts = lib32-gst-plugins-bad
diff --git a/.gitignore b/.gitignore
index 44cb76f637a7..c3d478557806 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,7 @@
*
!PKGBUILD
!.SRCINFO
-!0000-Allow-disabling-gstreamer.patch
-!0001-meson-Allow-building-with-system-orc.patch
!0002-HACK-meson-Disable-broken-tests.patch
!0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
!.gitignore
+!0001-Allow-disabling-gstreamer.patch
diff --git a/0000-Allow-disabling-gstreamer.patch b/0001-Allow-disabling-gstreamer.patch
index 13377d55a32f..13377d55a32f 100644
--- a/0000-Allow-disabling-gstreamer.patch
+++ b/0001-Allow-disabling-gstreamer.patch
diff --git a/0001-meson-Allow-building-with-system-orc.patch b/0001-meson-Allow-building-with-system-orc.patch
deleted file mode 100644
index 908174a48f80..000000000000
--- a/0001-meson-Allow-building-with-system-orc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
-Date: Mon, 6 Jun 2022 00:29:08 +0200
-Subject: [PATCH] meson: Allow building with system orc
-
----
- meson.build | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 617ba8a41461..509565e90891 100644
---- a/meson.build
-+++ b/meson.build
-@@ -112,7 +112,13 @@ elif build_system == 'darwin'
- subproject('macos-bison-binary')
- endif
-
--orc_subproject = subproject('orc', required: get_option('orc'))
-+orc_subproject_required = get_option('orc')
-+if orc_subproject_required.allowed()
-+ # Download if possible, otherwise use system orc
-+ orc_subproject_required = false
-+endif
-+
-+orc_subproject = subproject('orc', required: orc_subproject_required)
-
- foreach custom_subproj: get_option('custom_subprojects').split(',')
- if custom_subproj != ''
diff --git a/PKGBUILD b/PKGBUILD
index 3a449dff5987..60e0bc3076d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=(
lib32-gst-plugins-bad-latest
)
pkgver=1.20.5
-pkgrel=1
+pkgrel=2
pkgdesc="Multimedia graph framework (32-bit)"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@@ -37,14 +37,12 @@ checkdepends=(xorg-server-xvfb)
options=(!debug)
source=(
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git#tag=$pkgver"
- 0000-Allow-disabling-gstreamer.patch
- 0001-meson-Allow-building-with-system-orc.patch
+ 0001-Allow-disabling-gstreamer.patch
0002-HACK-meson-Disable-broken-tests.patch
0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
)
sha256sums=('SKIP'
'79b4d76bdb1ccf05099eff677d72cdf9df50788261891be41065aca21b4ea8b6'
- '292edebc224557db08404b0d53e2824413f0aad2a99c991de2cb8ccc6e9a7683'
'11971a978e37fda3822f95fb61b59ba3ded6487066dc59fcbde7b72a3a9cfe70'
'79d3038a0ba0c3958ffa8b5aec8431336b372906c07c0c878c3767bec0acb46f')
validpgpkeys=(D637032E45B8C6585B9456565D2EEE6F6F349D7C) # Tim Müller <tim@gstreamer-foundation.org>
@@ -56,13 +54,13 @@ pkgver() {
prepare() {
cd gstreamer
- git apply -3 ../0000-Allow-disabling-gstreamer.patch
- # Fix linking with system orc
- git apply -3 ../0001-meson-Allow-building-with-system-orc.patch
+
+ # Disable gstreamer
+ git apply -3 ../0001-Allow-disabling-gstreamer.patch
# Disable broken tests
git apply -3 ../0002-HACK-meson-Disable-broken-tests.patch
-
+
# Workaround broken detection of underscore prefixes
# https://github.com/mesonbuild/meson/issues/5482
git apply -3 ../0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
@@ -86,6 +84,7 @@ build() {
-D libav=disabled
-D libnice=disabled
-D omx=disabled
+ -D orc=disabled
-D python=disabled
-D qt5=disabled
-D rs=disabled
@@ -150,18 +149,31 @@ check() (
meson test -C build --print-errorlogs || :
)
+_cleanup() {
+ rm -rf "$pkgdir"/usr/{include,share}
+
+ if [[ -d "$pkgdir/usr/bin" ]];then
+ for _i in "$pkgdir"/usr/bin/*; do
+ mv "${_i}" "${_i}-32"
+ done
+ fi
+}
+
package_lib32-gst-libav-latest() {
pkgdesc+=" - libav plugin"
depends=("lib32-gst-plugins-base-libs=$pkgver" lib32-ffmpeg)
provides=("lib32-gst-ffmpeg=$pkgver" "lib32-gst-libav=$pkgver")
+ conflicts=('lib32-gst-libav')
DESTDIR="$pkgdir" meson install -C build \
--skip-subprojects gst-plugins-ugly,gst-plugins-bad
+ _cleanup
}
package_lib32-gst-plugins-bad-latest() {
pkgdesc+=" - bad plugins"
provides=("lib32-gst-plugins-bad=$pkgver")
+ conflicts=('lib32-gst-plugins-bad')
depends=(
"lib32-gst-plugins-bad-libs-latest=$pkgver" lib32-aom lib32-libass
lib32-libbs2b lib32-bzip2 lib32-chromaprint lib32-pango lib32-lcms2
@@ -186,14 +198,11 @@ package_lib32-gst-plugins-bad-libs-latest() {
lib32-libva lib32-libdrm lib32-libx11 lib32-libgudev lib32-libusb
)
provides=("lib32-gst-plugins-bad-libs=$pkgver")
+ conflicts=('lib32-gst-plugins-bad-libs')
DESTDIR="$pkgdir" meson install -C build \
--skip-subprojects gst-plugins-ugly,gst-libav
- rm -R "$pkgdir"/usr/{share,include}
-
- for _i in "$pkgdir"/usr/bin/*; do
- mv "${_i}" "${_i}-32"
- done
+ _cleanup
# bad-libs
local _libs _files
@@ -228,9 +237,11 @@ package_lib32-gst-plugins-ugly-latest() {
lib32-libdvdread lib32-libmpeg2 lib32-a52dec lib32-libsidplay lib32-libcdio lib32-x264 lib32-opencore-amr
)
provides=("lib32-gst-plugins-ugly=$pkgver")
+ conflicts=('lib32-gst-plugins-ugly')
DESTDIR="$pkgdir" meson install -C build \
--skip-subprojects gst-plugins-bad,gst-libav
+ _cleanup
}
# vim: ft=sh:ts=2:et: