summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:51:25 +0200
committeroli2015-06-12 21:51:25 +0200
commitab9fc6821a75356b5e0c7827a1088bc41dabd2cc (patch)
tree365dba909dc0d7512e8512e35cf8db41571e21b1
downloadaur-ab9fc6821a75356b5e0c7827a1088bc41dabd2cc.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
-rw-r--r--binreloc-cpp-fix.patch13
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f402bc912365
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = amoebax
+ pkgdesc = A cute and addictive action-puzzle game
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = http://www.emma-soft.com/games/amoebax/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = libpng
+ depends = libogg
+ depends = libvorbis
+ depends = gcc-libs
+ source = http://www.emma-soft.com/games/amoebax/download/amoebax-0.2.1.tar.bz2
+ source = binreloc-cpp-fix.patch
+ md5sums = 16835cf051334bd3d75345d879b23cdf
+ md5sums = 29a30fcc18689733022676a383ff3589
+
+pkgname = amoebax
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42ea5c577798
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Nick Bolten <Shirakawasuna at gmail _dot_ com>
+# Maintainer: Jose Riha <jose 1711 gmail com>
+
+pkgname=amoebax
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A cute and addictive action-puzzle game"
+arch=('i686' 'x86_64')
+url="http://www.emma-soft.com/games/amoebax/"
+license=('GPL')
+depends=('sdl_image' 'sdl_mixer' 'libpng' 'libogg' 'libvorbis' 'gcc-libs')
+source=(http://www.emma-soft.com/games/amoebax/download/${pkgname}-${pkgver}.tar.bz2 binreloc-cpp-fix.patch)
+md5sums=('16835cf051334bd3d75345d879b23cdf'
+ '29a30fcc18689733022676a383ff3589')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 < $srcdir/binreloc-cpp-fix.patch
+ ./configure --prefix=/usr
+ make
+ sed -i s,LogicGame,ArcadeGame,g $srcdir/$pkgname-$pkgver/data/$pkgname.desktop
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
diff --git a/binreloc-cpp-fix.patch b/binreloc-cpp-fix.patch
new file mode 100644
index 000000000000..41560edb17cd
--- /dev/null
+++ b/binreloc-cpp-fix.patch
@@ -0,0 +1,13 @@
+diff -r e882fce47fe0 src/binreloc.cxx
+--- a/src/binreloc.cxx Wed Jun 23 16:55:35 2010 +0200
++++ b/src/binreloc.cxx Wed Nov 10 21:41:41 2010 +0100
+@@ -739,7 +739,8 @@
+ char *
+ br_dirname (const char *path)
+ {
+- char *end, *result;
++ const char *end;
++ char *result;
+
+ if (path == (const char *) NULL)
+ return (char *) NULL;