summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJayson Reis2021-04-01 23:27:15 +0200
committerJayson Reis2021-04-01 23:27:15 +0200
commitabaa838e61500ec77963921e98262eb8ee5be84e (patch)
treebd907ec245e7f871e418aff82313c87a61f1b51e
downloadaur-abaa838e61500ec77963921e98262eb8ee5be84e.tar.gz
Add version 0.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8da57645dedd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mambembe-cli-without-keyring-bin
+ pkgdesc = Opensource Authy command line client (without keyring support)
+ pkgver = 0.1.0
+ pkgrel = 0
+ url = https://github.com/jaysonsantos/mambembe
+ arch = x86_64
+ license = MIT
+ depends = pacman>5
+ provides = mambembe-cli
+ conflicts = mambembe-cli
+ source = https://github.com/jaysonsantos/mambembe/releases/download/0.1.0/mambembe-cli-without-keyring-0.1.0-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = da0c9503da3f766ee5e68a5376778f04d83e8984d32190a480c3da8ffe607ce1
+
+pkgname = mambembe-cli-without-keyring-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83d0640bcca4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=mambembe-cli-without-keyring-bin
+_bin_name=mambembe-cli
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Opensource Authy command line client (without keyring support)"
+arch=('x86_64')
+url="https://github.com/jaysonsantos/mambembe"
+license=('MIT')
+depends=(
+ 'pacman>5'
+)
+provides=($_bin_name)
+conflicts=($_bin_name)
+source=("https://github.com/jaysonsantos/mambembe/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=('da0c9503da3f766ee5e68a5376778f04d83e8984d32190a480c3da8ffe607ce1')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install "${srcdir}/${_bin_name}" "${pkgdir}/usr/bin/${_bin_name}"
+}