summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Kozdrój2023-03-19 22:50:30 +0100
committerRafał Kozdrój2023-03-19 22:50:30 +0100
commitabaebd17ade6406a0f2b73936e9dde391c77a1d1 (patch)
tree6155c3de624f8fb4f0a649becc6040fc25251003
parent271cd91b351bd16e5ce1ca25ccb01d232b850eab (diff)
downloadaur-abaebd17ade6406a0f2b73936e9dde391c77a1d1.tar.gz
upgpkg: megasync 4.9.0.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--ffmpeg.patch29
3 files changed, 28 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4283d465ae89..1e7120afb8ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = megasync
pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive
- pkgver = 4.7.3.0
+ pkgver = 4.9.0.0
pkgrel = 1
url = https://github.com/meganz/MEGAsync
arch = i686
@@ -25,13 +25,13 @@ pkgbase = megasync
depends = libpdfium
depends = freeimage
depends = libudev.so
- source = git+https://github.com/meganz/MEGAsync.git#tag=v4.7.3.0_Linux
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v4.9.0.0_Linux
source = meganz-sdk::git+https://github.com/meganz/sdk.git
source = pdfium.patch
source = ffmpeg.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = bdad237f67d772789bf6e6835108827201296fc5cf793d28d94af8a1b04e56c9
- sha256sums = 939a46fb0c54f900156e9e68ec4369926e9610b1ca6e9fd6ca09e538fbb84688
+ sha256sums = d5fcd4018a665e7a591ab796569777cf0a74fadc7c953f6879f37c949f82e7ae
pkgname = megasync
diff --git a/PKGBUILD b/PKGBUILD
index bf0b20a21619..49bb1e17de52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
-pkgver=4.7.3.0
+pkgver=4.9.0.0
pkgrel=1
pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive"
arch=('i686' 'x86_64')
@@ -24,7 +24,7 @@ source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}${_extname}"
sha256sums=('SKIP'
'SKIP'
'bdad237f67d772789bf6e6835108827201296fc5cf793d28d94af8a1b04e56c9'
- '939a46fb0c54f900156e9e68ec4369926e9610b1ca6e9fd6ca09e538fbb84688')
+ 'd5fcd4018a665e7a591ab796569777cf0a74fadc7c953f6879f37c949f82e7ae')
prepare() {
cd "MEGAsync"
diff --git a/ffmpeg.patch b/ffmpeg.patch
index cd04e787b70e..9a1af1458e29 100644
--- a/ffmpeg.patch
+++ b/ffmpeg.patch
@@ -1,8 +1,21 @@
diff --git a/src/gfx/freeimage.cpp b/src/gfx/freeimage.cpp
-index b65b6f38f..e6ee148e1 100644
+index 2f685279a..e4b0a8c4a 100644
--- a/src/gfx/freeimage.cpp
+++ b/src/gfx/freeimage.cpp
-@@ -240,7 +240,7 @@ bool GfxProcFreeImage::readbitmapFfmpeg(FileAccess* fa, const LocalPath& imagePa
+@@ -209,12 +209,6 @@ bool GfxProviderFreeImage::readbitmapFreeimage(FileSystemAccess*, const LocalPat
+
+ #ifdef HAVE_FFMPEG
+
+-#ifdef AV_CODEC_CAP_TRUNCATED
+-#define CAP_TRUNCATED AV_CODEC_CAP_TRUNCATED
+-#else
+-#define CAP_TRUNCATED CODEC_CAP_TRUNCATED
+-#endif
+-
+ const char *GfxProviderFreeImage::supportedformatsFfmpeg()
+ {
+ return ".264.265.3g2.3gp.3gpa.3gpp.3gpp2.mp3"
+@@ -313,7 +307,7 @@ bool GfxProviderFreeImage::readbitmapFfmpeg(FileSystemAccess* fa, const LocalPat
// Find decoder for video stream
AVCodecID codecId = codecParm->codec_id;
@@ -11,11 +24,15 @@ index b65b6f38f..e6ee148e1 100644
if (!decoder)
{
LOG_warn << "Codec not found: " << codecId;
-@@ -257,7 +257,6 @@ bool GfxProcFreeImage::readbitmapFfmpeg(FileAccess* fa, const LocalPath& imagePa
+@@ -330,11 +324,6 @@ bool GfxProviderFreeImage::readbitmapFfmpeg(FileSystemAccess* fa, const LocalPat
// Force seeking to key frames
formatContext->seek2any = false;
- videoStream->skip_to_keyframe = true;
- if (decoder->capabilities & CAP_TRUNCATED)
- {
- codecContext->flags |= CAP_TRUNCATED;
+- if (decoder->capabilities & CAP_TRUNCATED)
+- {
+- codecContext->flags |= CAP_TRUNCATED;
+- }
+
+ AVPixelFormat sourcePixelFormat = static_cast<AVPixelFormat>(codecParm->format);
+ AVPixelFormat targetPixelFormat = AV_PIX_FMT_BGR24; //raw data expected by freeimage is in this format