summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-07-24 02:25:27 +0200
committerChristopher Arndt2020-07-24 02:25:27 +0200
commitabca2f467f366a96d73d3472972502346c2c027b (patch)
treeeaa703fd867cb780f9a3903857599dc315cb69f2
parent4fe1a7b2f4cf781aa65831ef6f368bbf8e97f9e3 (diff)
downloadaur-abca2f467f366a96d73d3472972502346c2c027b.tar.gz
Fix pkgver due to changing corner-case behaviour of 'git tag --sort'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5a444ac0feb..d2c5537861ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = foo-yc20-git
pkgdesc = An emulation of the Yamaha YC-20 combo organ as an LV2 plugin and a standalone program (git version)
pkgver = 1.3.0.r330.b99d4a3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/sampov2/foo-yc20
arch = x86_64
arch = armv7l
diff --git a/PKGBUILD b/PKGBUILD
index ac6e2451e340..672980936c46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _faust_version=0.9.73-mr2
_faust_commit=40a919756d09c6b2de19b3299b7eef55997551dc
pkgname="${_name}-git"
pkgver=1.3.0.r330.b99d4a3
-pkgrel=2
+pkgrel=3
pkgdesc="An emulation of the Yamaha YC-20 combo organ as an LV2 plugin and a standalone program (git version)"
arch=('x86_64' 'armv7l')
url="https://github.com/sampov2/foo-yc20"
@@ -16,6 +16,9 @@ makedepends=('git')
provides=("${_name}")
conflicts=("${_name}")
source=("${_name}::git+https://github.com/sampov2/foo-yc20.git"
+ # we need an obsolete version of FAUST as a build dependency,
+ # for which there is, unfortuantely, no release tag or archive
+ # just a branch, so we pin the commit for the checkout archive we're retrieving
"faust-${_faust_version}.tar.gz::https://github.com/grame-cncm/faust/archive/${_faust_commit}.tar.gz"
'foo-yc20-makefile-ldflags.patch')
sha256sums=('SKIP'
@@ -25,7 +28,7 @@ sha256sums=('SKIP'
pkgver() {
cd "${srcdir}/${_name}"
- local ver="$(git tag --sort=-taggerdate | head -n 1)"
+ local ver="$(git tag | sort -r | head -n 1)"
echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}