summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-06-12 18:25:59 +0200
committerNarrat2020-06-12 18:28:41 +0200
commitabe24c3d70bc88ddd42774c8006a7659ff23e484 (patch)
tree0aff153a6c639bcea049ed4905c3857fcbc7ea08
parenta4e167ee207bd626a2af1a7fac87fd59bcf8b7a1 (diff)
downloadaur-abe24c3d70bc88ddd42774c8006a7659ff23e484.tar.gz
atom-editor-git: Sync with community/atom
Partially, as one patch needed a further adjustment. Replace replaces with the proper conflicts
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
-rw-r--r--atom.js2
-rw-r--r--use-system-electron.patch35
4 files changed, 31 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb97de05c165..932a611b5f41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = atom-editor-git
pkgdesc = Hackable text editor for the 21st Century - git channel
- pkgver = 1.35.0.r1175.g48ca032eb
+ pkgver = 1.35.0.r1386.g527af1ad3
pkgrel = 1
url = https://atom.io/
arch = x86_64
@@ -9,12 +9,13 @@ pkgbase = atom-editor-git
makedepends = git
makedepends = npm
depends = apm
- depends = electron4
+ depends = electron5
depends = libxkbfile
depends = ripgrep
optdepends = ctags: symbol indexing support
optdepends = git: Git and GitHub integration
- replaces = atom-editor
+ provides = atom
+ conflicts = atom
options = !emptydirs
source = git+https://github.com/atom/atom.git
source = atom.js
@@ -29,7 +30,7 @@ pkgbase = atom-editor-git
source = use-system-apm.patch
source = use-system-electron.patch
sha256sums = SKIP
- sha256sums = d286e0766e47cfea73cd207abb9d6f7375846688823e72732c871a852b4b261d
+ sha256sums = 6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f
sha256sums = 530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153
sha256sums = b3d3706519556a59ba557b695017c9debe8b23efe2782cdb440131520bc0540d
sha256sums = 2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1
@@ -39,7 +40,7 @@ pkgbase = atom-editor-git
sha256sums = a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b
sha256sums = 3c68e6b3751313e1d386e721f8f819fb051351fb2cf8e753b1d773a0f475fef8
sha256sums = 8d48dca4571136375b325f4bf94ccfb996e90e57b7fdf83d53c1eb2e69b3b0d4
- sha256sums = 81af763f05c1afd87705b8c7a6647e35f524b2e952adb2e596de2a7e8fe4e69e
+ sha256sums = 84b03b2e68d2f86cd963a2e9327698545a8a782895594cf2cc9a74531c5c7875
pkgname = atom-editor-git
diff --git a/PKGBUILD b/PKGBUILD
index 1f133aa5ff32..3c1a00282ff3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,18 @@
_name=atom
pkgname=atom-editor-git
-pkgver=1.35.0.r1175.g48ca032eb
+pkgver=1.35.0.r1386.g527af1ad3
pkgrel=1
pkgdesc='Hackable text editor for the 21st Century - git channel'
arch=('x86_64')
url="https://atom.io/"
license=('MIT' 'custom')
-depends=('apm' 'electron4' 'libxkbfile' 'ripgrep')
+depends=('apm' 'electron5' 'libxkbfile' 'ripgrep')
makedepends=('git' 'npm')
optdepends=('ctags: symbol indexing support'
'git: Git and GitHub integration')
-replaces=('atom-editor')
+conflicts=('atom')
+provides=('atom')
options=(!emptydirs)
source=("git+https://github.com/atom/atom.git"
'atom.js'
@@ -30,7 +31,7 @@ source=("git+https://github.com/atom/atom.git"
'use-system-apm.patch'
'use-system-electron.patch')
sha256sums=('SKIP'
- 'd286e0766e47cfea73cd207abb9d6f7375846688823e72732c871a852b4b261d'
+ '6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f'
'530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153'
'b3d3706519556a59ba557b695017c9debe8b23efe2782cdb440131520bc0540d'
'2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1'
@@ -40,7 +41,7 @@ sha256sums=('SKIP'
'a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b'
'3c68e6b3751313e1d386e721f8f819fb051351fb2cf8e753b1d773a0f475fef8'
'8d48dca4571136375b325f4bf94ccfb996e90e57b7fdf83d53c1eb2e69b3b0d4'
- '81af763f05c1afd87705b8c7a6647e35f524b2e952adb2e596de2a7e8fe4e69e')
+ '84b03b2e68d2f86cd963a2e9327698545a8a782895594cf2cc9a74531c5c7875')
pkgver() {
@@ -66,7 +67,7 @@ build() {
ATOM_RESOURCE_PATH="${PWD}" \
npm_config_build_from_source=true \
- npm_config_target=$(< /usr/lib/electron4/version) \
+ npm_config_target=$(< /usr/lib/electron5/version) \
apm install
# Use system ctags
@@ -88,22 +89,18 @@ build() {
env \
npm_config_disturl=https://electronjs.org/headers \
npm_config_runtime=electron \
- npm_config_target=$(< /usr/lib/electron4/version) \
+ npm_config_target=$(< /usr/lib/electron5/version) \
node-gyp rebuild
cd ../..
cd script
- # Hack to avoid using Node 12
- env \
- npm_config_disturl=https://electronjs.org/headers \
- npm_config_runtime=electron \
- npm_config_target=$(< /usr/lib/electron4/version) \
- npm install
+ npm install
+ # Hack to avoid using Node > 12 (https://github.com/babel/babel/issues/11216)
# Set ELECTRON_VERSION (see use-system-electron.patch)
env \
ELECTRON_RUN_AS_NODE=1 \
- ELECTRON_VERSION=$(< /usr/lib/electron4/version) \
- electron4 \
+ ELECTRON_VERSION=$(< /usr/lib/electron5/version) \
+ electron5 \
build --no-bootstrap
}
diff --git a/atom.js b/atom.js
index f9c7e17d19c6..c3efd46e391e 100644
--- a/atom.js
+++ b/atom.js
@@ -1,4 +1,4 @@
-#!/usr/bin/electron4
+#!/usr/bin/electron5
const name = "atom";
diff --git a/use-system-electron.patch b/use-system-electron.patch
index 2cbc8b94e495..dddac2b8cc89 100644
--- a/use-system-electron.patch
+++ b/use-system-electron.patch
@@ -4,7 +4,7 @@
"url": "https://github.com/atom/atom/issues"
},
"license": "MIT",
-- "electronVersion": "4.2.7",
+- "electronVersion": "5.0.13",
"dependencies": {
"@atom/nsfw": "1.0.26",
"@atom/source-map-support": "^0.3.4",
@@ -19,7 +19,7 @@
const cleanOutputDirectory = require('./lib/clean-output-directory')
const codeSignOnMac = require('./lib/code-sign-on-mac')
const codeSignOnWindows = require('./lib/code-sign-on-windows')
-@@ -63,12 +63,12 @@
+@@ -64,12 +64,12 @@
})
const CONFIG = require('./config')
@@ -34,17 +34,18 @@
cleanOutputDirectory()
copyAssets()
transpilePackagesWithCustomTranspilerPaths()
-@@ -87,73 +87,5 @@
+@@ -88,74 +88,5 @@
if (!argv.generateApiDocs) {
binariesPromise
- .then(packageApplication)
.then(packagedAppPath => generateStartupSnapshot(packagedAppPath).then(() => packagedAppPath))
-- .then(packagedAppPath => {
+- .then(async packagedAppPath => {
- switch (process.platform) {
- case 'darwin': {
- if (argv.codeSign) {
-- codeSignOnMac(packagedAppPath)
+- await codeSignOnMac(packagedAppPath)
+- await notarizeOnMac(packagedAppPath)
- } else if (argv.testSign) {
- testSignOnMac(packagedAppPath)
- } else {
@@ -110,7 +111,7 @@
}
--- a/script/lib/generate-startup-snapshot.js
+++ b/script/lib/generate-startup-snapshot.js
-@@ -265,17 +265,14 @@
+@@ -286,17 +286,14 @@
CONFIG.executableName
);
} else {
@@ -118,7 +119,7 @@
- packagedAppPath,
- CONFIG.executableName
- );
-+ nodeBundledInElectronPath = 'electron4';
++ nodeBundledInElectronPath = 'electron5';
}
childProcess.execFileSync(
nodeBundledInElectronPath,
@@ -130,7 +131,7 @@
console.log('Generating startup blob with mksnapshot');
childProcess.spawnSync(process.execPath, [
path.join(
-@@ -317,5 +314,6 @@
+@@ -338,5 +335,6 @@
destinationPath
);
}
@@ -143,9 +144,9 @@
"coffeelint": "1.15.7",
"colors": "1.1.2",
"donna": "1.0.16",
-- "electron-chromedriver": "^4.2.0",
- "electron-link": "0.4.0",
-- "electron-mksnapshot": "^4.2.0",
+- "electron-chromedriver": "^9.0.0",
+ "electron-link": "0.4.1",
+- "electron-mksnapshot": "^9.0.2",
"electron-packager": "12.2.0",
"@atom/electron-winstaller": "0.0.1",
"eslint": "^5.16.0",
@@ -160,18 +161,6 @@
name: null
};
}
---- a/src/main-process/atom-window.js
-+++ b/src/main-process/atom-window.js
-@@ -47,7 +47,8 @@
- // Disable the `auxclick` feature so that `click` events are triggered in
- // response to a middle-click.
- // (Ref: https://github.com/atom/atom/pull/12696#issuecomment-290496960)
-- disableBlinkFeatures: 'Auxclick'
-+ disableBlinkFeatures: 'Auxclick',
-+ nodeIntegration: true
- }
- };
-
--- a/src/module-cache.js
+++ b/src/module-cache.js
@@ -270,7 +270,7 @@