summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2021-06-03 12:44:49 +0200
committerCayetano Santos2021-06-03 12:44:49 +0200
commitabe51ccbc6a36e24ef26d0ab8969b9f914964d7c (patch)
tree614154ac5a4397e71a2ac060a7b20a4070fd4b51
parentd54e5a15ccbec88d7239e2203d02a3ec37f24689 (diff)
downloadaur-abe51ccbc6a36e24ef26d0ab8969b9f914964d7c.tar.gz
Fix issue with setuptools-scm
https://github.com/cocotb/cocotb-bus/issues/21
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cf56ea2edd6..5acd3fa5e7c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = python-cocotb-bus
license = BSD
makedepends = git
depends = python
- depends = python-setuptools
+ depends = python-setuptools-scm
optdepends = iverilog: for simulating verilog designs
optdepends = ghdl: for simulating VHDL designs
optdepends = gtkwave: for visualizing waveforms
@@ -16,4 +16,3 @@ pkgbase = python-cocotb-bus
md5sums = SKIP
pkgname = python-cocotb-bus
-
diff --git a/PKGBUILD b/PKGBUILD
index 8b2eb20e5b95..dec4a232d301 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="Pre-packaged testbenching tools and reusable bus interfaces for cocotb"
arch=('any')
url="https://github.com/cocotb/cocotb-bus/"
license=('BSD')
-depends=('python' 'python-setuptools')
+depends=('python' 'python-setuptools-scm')
makedepends=('git')
optdepends=('iverilog: for simulating verilog designs'