summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2021-07-19 09:48:28 +0300
committerAdrian Perez de Castro2021-07-19 09:48:28 +0300
commitabeb6849ec0c2005343304fb6454c2792d0ec261 (patch)
tree7958070bedb9f5f2b5ceca642ce65b242b93c5fb
parent3d7ef1cbc9fe986d68af5e2f3669ff4892478665 (diff)
downloadaur-abeb6849ec0c2005343304fb6454c2792d0ec261.tar.gz
Bring up to date, dark/breeze variants are gone
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD37
2 files changed, 19 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf8f8d3a5c17..bf7c11cea9d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xcursor-simp1e
pkgdesc = An aesthetic cursor theme
- pkgver = 0.0.20210227
+ pkgver = 0.0.20210719
pkgrel = 1
url = https://gitlab.com/zoli111/simp1e/
arch = any
@@ -9,12 +9,9 @@ pkgbase = xcursor-simp1e
makedepends = inkscape
makedepends = python2
makedepends = xorg-xcursorgen
- source = xcursor-simp1e::git+https://gitlab.com/zoli111/simp1e/?commit=1ec1162934606861cda71b4658a50df597fa52e1
+ source = xcursor-simp1e::git+https://gitlab.com/zoli111/simp1e/#commit=995f50da41786263c89f10ddb72416a61462c973
+ source = builder_script::git+https://github.com/mxre/cursor
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = xcursor-simp1e
-
-pkgname = xcursor-simp1e-dark
-
-pkgname = xcursor-simp1e-breeze
-
diff --git a/PKGBUILD b/PKGBUILD
index 8106588279da..fffcd68e7c6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,31 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
-pkgbase=xcursor-simp1e
-pkgname=(xcursor-simp1e{,-dark,-breeze})
+pkgname=xcursor-simp1e
pkgdesc='An aesthetic cursor theme'
-pkgver=0.0.20210227
+pkgver=0.0.20210719
pkgrel=1
url=https://gitlab.com/zoli111/simp1e/
-_commit=1ec1162934606861cda71b4658a50df597fa52e1
+_commit=995f50da41786263c89f10ddb72416a61462c973
arch=(any)
makedepends=(git inkscape python2 xorg-xcursorgen)
depends=()
license=(GPL3)
-source=("${pkgname}::git+${url}?commit=${_commit}")
-sha512sums=(SKIP)
+source=("${pkgname}::git+${url}#commit=${_commit}"
+ "builder_script::git+https://github.com/mxre/cursor")
+sha512sums=(SKIP SKIP)
-_variants=(Simp1e Simp1e-dark Simp1e-breeze)
+prepare () {
+ cd "${pkgname}"
+ git submodule init
+ git config submodule.builder_script.url "${srcdir}/builder_script"
+ git submodule update
+}
build () {
cd "${pkgname}"
- yes | ./build.sh
+ ./build.sh
}
-_package () {
+package () {
install -dm755 "${pkgdir}/usr/share/icons"
- cp -a "${pkgbase}/BuiltThemes/$1/$1" "${pkgdir}/usr/share/icons"
-}
-
-package_xcursor-simp1e () {
- _package Simp1e
-}
-
-package_xcursor-simp1e-dark () {
- _package Simp1e-dark
-}
-
-package_xcursor-simp1e-breeze () {
- _package Simp1e-breeze
+ cp -a "${pkgbase}/built_themes/Simp1e" "${pkgdir}/usr/share/icons"
}