summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElaina Martineau2019-12-11 13:19:03 -0700
committerElaina Martineau2019-12-11 13:19:38 -0700
commitabf3b46f5e4461258201aaed4619a307ed33a1b1 (patch)
tree3e50dc0074ca717b3bd2a87a6b1da47c8f5e5f1e
parent5c23b8c32f6d6958ae42b4b353dde5f33f770ea3 (diff)
downloadaur-abf3b46f5e4461258201aaed4619a307ed33a1b1.tar.gz
Update to v113
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD8
-rw-r--r--package.patch22
3 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 156ca941f617..c8370aef142c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bsnes
pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use.
- pkgver = 112
+ pkgver = 113
pkgrel = 1
url = https://byuu.org/emulation/bsnes/
arch = x86_64
@@ -13,10 +13,10 @@ pkgbase = bsnes
depends = sdl2
conflicts = bsnes-classic
conflicts = bsnes-plus
- source = https://download.byuu.org/bsnes_v112-source.zip
+ source = https://download.byuu.org/bsnes_v113-source.zip
source = package.patch
- sha256sums = 012bb38ae778ef5bc32eda067ec7b574441a0c46c4e0f612488163f3fe23e629
- sha256sums = e800849a4e6c9b431578c2c55bfaab7b0619629ba34bd97f38bae64d5f2412d6
+ sha256sums = 0b0ddefcfb367db4ce3c994e82f72f529ba2a18a94ea7f8954818a84c61371ac
+ sha256sums = f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb
pkgname = bsnes
diff --git a/PKGBUILD b/PKGBUILD
index f3854facb00c..33e35ceecb47 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Elaina Martineau <elainamartineau@gmail.com>
pkgname=bsnes
-pkgver=112
+pkgver=113
pkgrel=1
pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
arch=('x86_64')
@@ -10,13 +10,13 @@ license=('GPL3')
depends=('libpulse' 'gtksourceview2' 'libxv' 'libao' 'openal' 'sdl2')
conflicts=('bsnes-classic' 'bsnes-plus')
source=("https://download.byuu.org/${pkgname}_v${pkgver//./r}-source.zip" 'package.patch')
-sha256sums=('012bb38ae778ef5bc32eda067ec7b574441a0c46c4e0f612488163f3fe23e629'
- 'e800849a4e6c9b431578c2c55bfaab7b0619629ba34bd97f38bae64d5f2412d6')
+sha256sums=('0b0ddefcfb367db4ce3c994e82f72f529ba2a18a94ea7f8954818a84c61371ac'
+ 'f391b8ce83ed1dfe93d83484464613de1fa1c454d69b02c5234efc9ef69fd3bb')
prepare() {
cd "${pkgname}_v${pkgver//./r}-source"
- patch --forward --strip=1 --input="${srcdir}/package.patch"
+ patch --forward --strip=1 --input="${srcdir}/package.patch" --ignore-whitespace
}
build() {
diff --git a/package.patch b/package.patch
index 8512d3fd1f22..e1215507a360 100644
--- a/package.patch
+++ b/package.patch
@@ -13,17 +13,15 @@ diff --unified --recursive bsnes_v108-source.orig/bsnes/GNUmakefile bsnes_v108-s
flags += -I. -I..
-diff --unified --recursive bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile
---- bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:51:07.601683406 -0700
-+++ bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:52:00.013706440 -0700
-@@ -34,9 +34,7 @@
- verbose: hiro.verbose ruby.verbose nall.verbose all;
-
+diff --unified --recursive bsnes_v113-source.orig/bsnes/target-bsnes/GNUmakefile bsnes_v113-source.new/bsnes/target-bsnes/GNUmakefile
+--- bsnes_v113-source.orig/bsnes/target-bsnes/GNUmakefile 2019-12-11 12:19:18.782618740 -0700
++++ bsnes_v113-source.new/bsnes/target-bsnes/GNUmakefile 2019-12-11 12:20:36.969034855 -0700
+@@ -40,8 +40,6 @@
+
install: all
--ifeq ($(shell id -un),root)
-- $(error "make install should not be run as root")
--else ifeq ($(platform),windows)
-+ifeq ($(platform),windows)
+ ifeq ($(platform),windows)
+-else ifeq ($(shell id -un),root)
+- $(error "make install should not be run as root")
else ifeq ($(platform),macos)
- mkdir -p ~/Library/Application\ Support/$(name)/
- cp -R out/$(name).app /Applications/$(name).app
+ mkdir -p ~/Library/Application\ Support/$(name)/
+ mkdir -p ~/Library/Application\ Support/$(name)/Database/