summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPer Osbäck2021-11-21 08:54:48 +0100
committerPer Osbäck2021-11-21 08:54:48 +0100
commitabf91c72265ef6c08eca773ef4096406164de160 (patch)
tree3b1aefc03f97788d2572162eab9f2c5bac142d6f
parentcc4ef09b3edd705e4886803d75b4224d5f2e8690 (diff)
downloadaur-abf91c72265ef6c08eca773ef4096406164de160.tar.gz
bump 0.8.2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 081a2c25c235..63d9cde16ff8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = perfops-cli
pkgdesc = A simple command line tool to interact with hundreds of servers around the world. Run benchmarks and debug your infrastructure without leaving your console.
- pkgver = 0.8.1
+ pkgver = 0.8.2
pkgrel = 1
url = https://perfops.net
arch = x86_64
license = APACHE
makedepends = git
makedepends = go
- source = perfops-cli::git+https://github.com/ProspectOne/perfops-cli.git#tag=v0.8.1
+ source = perfops-cli::git+https://github.com/ProspectOne/perfops-cli.git#tag=v0.8.2
sha256sums = SKIP
pkgname = perfops-cli
-
diff --git a/PKGBUILD b/PKGBUILD
index 15db6a1da5b4..ab74dad9fb48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Per Osbeck <per@osbeck.com>
pkgname=perfops-cli
-pkgver=0.8.1
+pkgver=0.8.2
pkgrel=1
pkgdesc="A simple command line tool to interact with hundreds of servers around the world. Run benchmarks and debug your infrastructure without leaving your console."
arch=(x86_64)
@@ -12,15 +12,9 @@ sha256sums=(SKIP)
build() {
cd "$pkgname"
- GOPATH="$srcdir" PERFOPS_BUILD_PLATFORMS=linux bash hack/build-all.sh
-}
-
-prepare() {
- mkdir -p "src/github.com/ProspectOne"
- ln -sf "$srcdir/$pkgname" "src/github.com/ProspectOne/$pkgname"
+ GOPATH="$srcdir" PERFOPS_BUILD_PLATFORMS=linux go get -u github.com/ProspectOne/perfops-cli
}
package() {
- cd "$pkgname"
- install -Dm755 "release/perfops-linux-amd64" "$pkgdir/usr/bin/perfops-cli"
+ install -Dm755 "bin/perfops-cli" "$pkgdir/usr/bin/perfops-cli"
}