summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-07 17:35:50 +0800
committerzxp198210052023-12-07 17:35:50 +0800
commitac06dbfb69e0555217406d54380d915d2c7e1cd7 (patch)
tree8cad620cc76955369c9bb4704b0ac036b28c4691
parent02a6b3f76bcdddaf60d21c00854f913a8cbdee0a (diff)
downloadaur-ac06dbfb69e0555217406d54380d915d2c7e1cd7.tar.gz
update to 4.0.0.canary.5.r250.ga1da6e79
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
-rw-r--r--hyper.sh14
3 files changed, 24 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4944f159c1e..4cbf1d5fbfb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,13 +12,11 @@ pkgbase = hyper-git
makedepends = python>=3.8
makedepends = libarchive
makedepends = libicns
- depends = bash
depends = python
depends = alsa-lib
depends = libxfixes
depends = cairo
depends = libxcb
- depends = glibc
depends = nspr
depends = at-spi2-core
depends = pango
@@ -29,20 +27,15 @@ pkgbase = hyper-git
depends = libxcomposite
depends = gtk3
depends = libxkbcommon
- depends = gcc-libs
depends = libxext
depends = mesa
depends = libxdamage
depends = libxrandr
depends = libdrm
- depends = glib2
- depends = dbus
depends = hicolor-icon-theme
provides = hyper
conflicts = hyper
source = hyper::git+https://github.com/vercel/hyper.git
- source = hyper.sh
sha256sums = SKIP
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
pkgname = hyper-git
diff --git a/PKGBUILD b/PKGBUILD
index 3feb4860324f..fb03d138a9a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,29 @@ arch=('any')
url="https://hyper.is/"
_ghurl="https://github.com/vercel/hyper"
license=('MIT')
-depends=('bash' 'python' 'alsa-lib' 'libxfixes' 'cairo' 'libxcb' 'glibc' 'nspr' 'at-spi2-core' 'pango' 'nss' 'libx11' 'libcups' 'expat' \
- 'libxcomposite' 'gtk3' 'libxkbcommon' 'gcc-libs' 'libxext' 'mesa' 'libxdamage' 'libxrandr' 'libdrm' 'glib2' 'dbus' 'hicolor-icon-theme')
+depends=(
+ 'python'
+ 'alsa-lib'
+ 'libxfixes'
+ 'cairo'
+ 'libxcb'
+ 'nspr'
+ 'at-spi2-core'
+ 'pango'
+ 'nss'
+ 'libx11'
+ 'libcups'
+ 'expat'
+ 'libxcomposite'
+ 'gtk3'
+ 'libxkbcommon'
+ 'libxext'
+ 'mesa'
+ 'libxdamage'
+ 'libxrandr'
+ 'libdrm'
+ 'hicolor-icon-theme'
+)
makedepends=(
'git'
'npm>=9.8.1'
@@ -30,10 +51,8 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(
"${pkgname%-git}::git+${_ghurl}.git"
- "${pkgname%-git}.sh"
)
-sha256sums=('SKIP'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
printf "%s" "$(git describe --tags | sed 's/\w\+\///g;s/\([^-]*-g\)/r\1/;s/-/./g;s/v//g')"
@@ -45,10 +64,6 @@ _ensure_local_nvm() {
nvm use 18
}
build() {
- sed -e "s|@electronversion@|${_electronversion}|" \
- -e "s|@appname@|${pkgname%-git}|g" \
- -e "s|@appasar@|app|g" \
- -i "${srcdir}/${pkgname%-git}.sh"
_ensure_local_nvm
gendesk -q -f -n --categories "System;Utility" --name "${_pkgname}" --exec "${pkgname%-git} --no-sandbox %U"
cd "${srcdir}/${pkgname%-git}"
diff --git a/hyper.sh b/hyper.sh
deleted file mode 100644
index 2ec4412e5c4f..000000000000
--- a/hyper.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/bash
-set -e
-_APPDIR="/usr/lib/@appname@"
-export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
-export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
-if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
-else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file