summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTavian Barnes2022-05-31 16:23:00 -0400
committerTavian Barnes2022-05-31 16:23:57 -0400
commitac23347b42f674d785e77b42d46e35e7de1c6a6f (patch)
tree65f02b9bfd60c0fd27fa87448a28fe6dace1715a
parent3a5c535c4622db23b4e76af40561cbe795175240 (diff)
downloadaur-ac23347b42f674d785e77b42d46e35e7de1c6a6f.tar.gz
Fix the build with LLVM 13 by using the upstream llvm-13.0 branch
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 14 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d5ff6e29def..a0ddad71c935 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = creduce
pkgdesc = A C/C++ program reducer
- pkgver = 2.10.0
- pkgrel = 3
+ pkgver = 2.10.0.r94.4ae77d1
+ pkgrel = 1
url = https://embed.cs.utah.edu/creduce/
arch = i686
arch = x86_64
@@ -15,15 +15,7 @@ pkgbase = creduce
depends = perl-file-which
depends = perl-getopt-tabular
depends = perl-regexp-common
- source = https://embed.cs.utah.edu/creduce/creduce-2.10.0.tar.gz
- source = 0001-Link-clang_delta-only-with-lclang-cpp-193.patch
- source = 0002-Make-it-compile-with-LLVM11.patch
- md5sums = ec9d5fd3c71840c7361cdf626fe1f202
- md5sums = 40d922b34f0d820ac61a8274093094ba
- md5sums = df763f8f9a52bbdc8e8da6b574fd8d1b
- sha256sums = db1c0f123967f24d620b040cebd53001bf3dcf03e400f78556a2ff2e11fea063
- sha256sums = eb5b1d38a35b2f6b74db49ce0e9d29b287694915d17941cdf1455cd34fe967df
- sha256sums = 837c18c5d3cea9d51a52aeb5f191e00275b7f9ba09116b26a13f478d59f848bb
+ source = creduce::git+https://github.com/csmith-project/creduce.git#commit=4ae77d1e101135a6aea310b30c19e2af968b7bf6
+ sha256sums = SKIP
pkgname = creduce
-
diff --git a/.gitignore b/.gitignore
index 1506182b09fa..5e02babd5df2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
/*.pkg.tar.*
/pkg/
/src/
+/creduce/
diff --git a/PKGBUILD b/PKGBUILD
index d3b5ad5cb745..89e71bb7bb74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tavian Barnes <tavianator@tavianator.com>
pkgname=creduce
-pkgver=2.10.0
-pkgrel=3
+pkgver=2.10.0.r94.4ae77d1
+pkgrel=1
epoch=
pkgdesc="A C/C++ program reducer"
arch=('i686' 'x86_64')
@@ -11,29 +11,21 @@ license=('custom:University of Illinois Open Source License')
depends=('astyle' 'clang>=9.0.0' 'indent' 'llvm>=9.0.0'
'perl-benchmark-timer' 'perl-exporter-lite' 'perl-file-which'
'perl-getopt-tabular' 'perl-regexp-common')
-source=("https://embed.cs.utah.edu/$pkgname/$pkgname-$pkgver.tar.gz"
- '0001-Link-clang_delta-only-with-lclang-cpp-193.patch'
- '0002-Make-it-compile-with-LLVM11.patch')
-md5sums=('ec9d5fd3c71840c7361cdf626fe1f202'
- '40d922b34f0d820ac61a8274093094ba'
- 'df763f8f9a52bbdc8e8da6b574fd8d1b')
-sha256sums=('db1c0f123967f24d620b040cebd53001bf3dcf03e400f78556a2ff2e11fea063'
- 'eb5b1d38a35b2f6b74db49ce0e9d29b287694915d17941cdf1455cd34fe967df'
- '837c18c5d3cea9d51a52aeb5f191e00275b7f9ba09116b26a13f478d59f848bb')
+source=('creduce::git+https://github.com/csmith-project/creduce.git#commit=4ae77d1e101135a6aea310b30c19e2af968b7bf6')
+sha256sums=('SKIP')
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/0001-Link-clang_delta-only-with-lclang-cpp-193.patch"
- patch -p1 -i "$srcdir/0002-Make-it-compile-with-LLVM11.patch"
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -E 's/creduce-([^-]*)-([^-]*)-g/\1-r\2-/; s/-/./g'
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
./configure --prefix=/usr
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
make install DESTDIR="$pkgdir/"
}