summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRecolic Keghart2018-04-14 15:50:20 +0800
committerRecolic Keghart2018-04-14 15:50:20 +0800
commitac3655ae0be2f8898197fe909f4205d362318eda (patch)
tree067001d4faea81d6b93de46373c4fd666ce2c5e8
parent7b481a9e57a3704514cddd9053278515f3b70354 (diff)
downloadaur-ac3655ae0be2f8898197fe909f4205d362318eda.tar.gz
1.3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b0516c39a8..1ba3154309b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snakesocks
pkgdesc = An extensible proxy which prevents some ISP from detecting network traffic.
- pkgver = 1.3.0
- pkgrel = 4
+ pkgver = 1.3.1
+ pkgrel = 0
url = https://github.com/SnakeSocks/snakesocks
arch = i686
arch = x86_64
@@ -16,10 +16,10 @@ pkgbase = snakesocks
replaces = snakesocks-bin
backup = etc/snakesocks/conf/client.conf
backup = etc/snakesocks/conf/server.conf
- source = snakesocks-1.3.0.tar.gz::https://github.com/SnakeSocks/snakesocks/archive/v1.3.0-3.tar.gz
- source = snakesocks-1.3.0.tar.gz.sig::https://s.recn.pw/v1.3.0-3.tar.gz.sig
+ source = snakesocks-1.3.1.tar.gz::https://github.com/SnakeSocks/snakesocks/archive/v1.3.1.tar.gz
+ source = snakesocks-1.3.1.tar.gz.sig::https://s.recn.pw/v1.3.1.tar.gz.sig
validpgpkeys = 00D386A853D34998CC1D232A99B730DA4B48AF32
- sha256sums = f3619be786a69775ba8885643f0b08e1a039169bd8ceb19b4e75967b0e0cebf6
+ sha256sums = d719c41351d731822637aac6a86934bab42cb4274f11e29947dd7a97b472db5a
sha256sums = SKIP
pkgname = snakesocks
diff --git a/PKGBUILD b/PKGBUILD
index 01276929a619..cf79a6774e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
# I'm really sorry but providing our name is dangerous to us. Github: https://github.com/snakesocks
pkgname=snakesocks
-pkgver=1.3.0
-# real version is 1.3.0-3... I will repair that on 1.3.1
-pkgrel=4
+pkgver=1.3.1
+pkgrel=0
pkgdesc="An extensible proxy which prevents some ISP from detecting network traffic."
url="https://github.com/SnakeSocks/$pkgname"
license=("GPL2")
@@ -14,15 +13,15 @@ makedepends=("boost>=1.55" "go" "cmake>=3.5" "make")
conflicts=("$pkgname-bin")
replaces=("$pkgname-bin")
backup=("etc/$pkgname/conf/client.conf" "etc/$pkgname/conf/server.conf")
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver-3.tar.gz"
- "$pkgname-$pkgver.tar.gz.sig::https://s.recn.pw/v$pkgver-3.tar.gz.sig")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.sig::https://s.recn.pw/v$pkgver.tar.gz.sig")
validpgpkeys=("00D386A853D34998CC1D232A99B730DA4B48AF32")
-sha256sums=("f3619be786a69775ba8885643f0b08e1a039169bd8ceb19b4e75967b0e0cebf6"
+sha256sums=("d719c41351d731822637aac6a86934bab42cb4274f11e29947dd7a97b472db5a"
"SKIP")
package() {
export pkgdir
- cd "$pkgname-$pkgver-3"
+ cd "$pkgname-$pkgver"
make default_modules
make client # requires cmake and boost
make server # requires go. comment it if you dont want it.