summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmanuDel-diavolo2020-09-07 19:57:03 +0000
committerAmanuDel-diavolo2020-09-07 19:57:03 +0000
commitac4bacb29f818347ff6be8865cd5a14d3fc71925 (patch)
tree9bb018394676660f8750ad2219d873ce7c0d6dd7
parentb794609bf75e8642362a160735364355c2eaea9d (diff)
downloadaur-ac4bacb29f818347ff6be8865cd5a14d3fc71925.tar.gz
fixed some typos and some permissions to the executable
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88446808668e..cd0f7372c674 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,7 @@
pkgbase = ssacli
+ pkgdesc = The HPE Smart Storage Administrator CLI is a commandline-based disk configuration program that helps you configure, manage, diagnose, and monitor HPE ProLiant Smart Array Controllers
pkgver = 4.17.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_9697c6899a664d02b9c3436674
arch = x86_64
groups = hpproliant
diff --git a/PKGBUILD b/PKGBUILD
index 8232791aa1ed..910e8c396fb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=ssacli
pkgver=4.17.6.0
-pkgrel=1
-pkgdesk="The HPE Smart Storage Administrator CLI is a commandline-based disk configuration program that helps you configure, manage, diagnose, and monitor HPE ProLiant Smart Array Controllers"
+pkgrel=2
+pkgdesc="The HPE Smart Storage Administrator CLI is a commandline-based disk configuration program that helps you configure, manage, diagnose, and monitor HPE ProLiant Smart Array Controllers"
arch=('x86_64')
url="https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_9697c6899a664d02b9c3436674"
replaces=(hpacucli hpssacli)
@@ -26,14 +26,16 @@ package() {
cp -r "${srcdir}/usr/sbin" "${pkgdir}/usr/bin"
cp -r "${srcdir}/usr/man" "${pkgdir}/usr/share/man"
- #striping the binaries
+ #changing permission to the binaries to strip
chmod 755 "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssacli"
chmod 755 "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssascripting"
- chmod 755 "${pkgdir}/usr/bin/ssacli"
- chmod 755 "${pkgdir}/usr/bin/ssascripting"
- #striping the binaries
+ #stripping the binaries
strip --strip-unneeded "${pkgdir}/opt/smartstorageadmin/ssacli/bin/rmstr"
strip --strip-unneeded "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssacli"
strip --strip-unneeded "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssascripting"
+
+ #changing permission to the binaries after stripping
+ chmod 500 "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssacli"
+ chmod 500 "${pkgdir}/opt/smartstorageadmin/ssacli/bin/ssascripting"
}