summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrhysd2023-06-20 10:01:51 +0900
committerrhysd2023-06-20 10:01:51 +0900
commitac590616f36b9753e7d1736d3d596a35a5845e83 (patch)
treedccd45c29a41980da37c9e36a9931a9620a2977d
parente7cd69650e93f551b28ea0d8a709a5a2e5cb1f78 (diff)
downloadaur-ac590616f36b9753e7d1736d3d596a35a5845e83.tar.gz
actionlint: Fix running unit tests
This fixes https://github.com/rhysd/actionlint/issues/307
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b10b2eaa5dae..855454e2f4f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,6 +29,9 @@ build() {
check() {
cd "$pkgname-$pkgver"
+ # To run tests for actionlint, `.git` directory is needed.
+ # actionlint finds a root of repository by checking the directory.
+ mkdir -p .git
go test -v ./ ./scripts/...
}