summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmaël Bouya2016-03-14 02:59:27 +0100
committerIsmaël Bouya2016-03-14 02:59:27 +0100
commitac596e9c4da2f53757e7e4979d48f209cdf0b1b7 (patch)
tree6b45c3cb6d03de666fa0ad92655ab6d56745458b
parent7925e5eee3e81544175b7f7d288c96d11c6bc9aa (diff)
downloadaur-ac596e9c4da2f53757e7e4979d48f209cdf0b1b7.tar.gz
Sort notes by title
-rw-r--r--.SRCINFO6
-rw-r--r--002_sort_found_notes.patch11
-rw-r--r--PKGBUILD7
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d872cdd945e..d9bdbaf31af0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Mar 14 01:49:00 UTC 2016
+# Mon Mar 14 01:59:15 UTC 2016
pkgbase = terminal_velocity-git
pkgdesc = A fast note-taking app for the UNIX terminal (patched)
pkgver = 0.96.5667177
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/seanh/terminal_velocity
arch = any
license = GPL
@@ -12,8 +12,10 @@ pkgbase = terminal_velocity-git
depends = python2-chardet
source = git://github.com/seanh/terminal_velocity.git
source = 001_fix_shell_escape.patch
+ source = 002_sort_found_notes.patch
sha1sums = SKIP
sha1sums = 7b04f0f28a4801931f7a0e499f5131d5a5c3653c
+ sha1sums = 426613e5620251c37854e489b21e4790c6c7df3b
pkgname = terminal_velocity-git
diff --git a/002_sort_found_notes.patch b/002_sort_found_notes.patch
new file mode 100644
index 000000000000..6053037b74d7
--- /dev/null
+++ b/002_sort_found_notes.patch
@@ -0,0 +1,11 @@
+--- a/urwid_ui.py 2016-03-14 02:56:30.348210225 +0100
++++ b/urwid_ui.py 2016-03-14 02:56:38.421447101 +0100
+@@ -409,7 +409,7 @@
+
+ # Sort the notes.
+ # TODO: Support different sort orderings.
+- matching_notes.sort(key=lambda x: x.mtime, reverse=True)
++ matching_notes.sort(key=lambda x: x.title)
+
+ # Tell the list box to show only the matching notes.
+ self.list_box.filter(matching_notes)
diff --git a/PKGBUILD b/PKGBUILD
index ce7be8df2db0..2242376b2e1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=terminal_velocity
pkgname=terminal_velocity-git
pkgver=0.96.5667177
-pkgrel=2
+pkgrel=3
pkgdesc="A fast note-taking app for the UNIX terminal (patched)"
arch=('any')
url="https://github.com/seanh/terminal_velocity"
@@ -13,9 +13,11 @@ makedepends=('git')
source=(
'git://github.com/seanh/terminal_velocity.git'
'001_fix_shell_escape.patch'
+ '002_sort_found_notes.patch'
)
sha1sums=('SKIP'
- '7b04f0f28a4801931f7a0e499f5131d5a5c3653c')
+ '7b04f0f28a4801931f7a0e499f5131d5a5c3653c'
+ '426613e5620251c37854e489b21e4790c6c7df3b')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -25,6 +27,7 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname/$_pkgname"
patch -p1 < ../../001_fix_shell_escape.patch
+ patch -p1 < ../../002_sort_found_notes.patch
cd "$srcdir/$_pkgname"
python2 setup.py build
}