summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre LALET2019-03-17 13:51:59 +0100
committerPierre LALET2019-03-17 13:51:59 +0100
commitac65ac306a6b929e6e0d55bd0619633acda8790b (patch)
tree70283f0bc85f95785a52d92c000d0bf29c5ae448
parentbd165a31b0efc72478bbdfdfccfe4f243903cffa (diff)
downloadaur-ac65ac306a6b929e6e0d55bd0619633acda8790b.tar.gz
Version bump, add provides / conflicts
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89d25c4cb408..ebb65979b270 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = miasm-git
pkgdesc = Machine code manipulation library
- pkgver = 0.1.1.dev89
+ pkgver = 0.1.1.dev91
pkgrel = 1
url = https://miasm.re/
arch = any
@@ -18,6 +18,8 @@ pkgname = python-miasm-git
optdepends = python-llvmlite: jit with LLVM engine, bridge between Miasm and LLVM IRs
optdepends = python-pycparser: additional features based on type manipulations
optdepends = python-z3: additional features based on constraint solving
+ provides = python-miasm
+ conflicts = python-miasm
pkgname = python2-miasm-git
depends = python2
@@ -26,4 +28,6 @@ pkgname = python2-miasm-git
optdepends = python2-llvmlite: jit with LLVM engine, bridge between Miasm and LLVM IRs
optdepends = python2-pycparser: additional features based on type manipulations
optdepends = python2-z3: additional features based on constraint solving
+ provides = python2-miasm
+ conflicts = python2-miasm
diff --git a/PKGBUILD b/PKGBUILD
index 5d440f232f49..321fe451bab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase='miasm-git'
pkgbasename='miasm'
pkgname=('python-miasm-git' 'python2-miasm-git')
-pkgver=0.1.1.dev89
+pkgver=0.1.1.dev91
pkgrel=1
pkgdesc='Machine code manipulation library'
arch=('any')
@@ -38,6 +38,8 @@ package_python-miasm-git() {
optdepends=('python-llvmlite: jit with LLVM engine, bridge between Miasm and LLVM IRs'
'python-pycparser: additional features based on type manipulations'
'python-z3: additional features based on constraint solving')
+ provides=('python-miasm')
+ conflicts=('python-miasm')
cd "$srcdir/$pkgbasename"
python setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
@@ -48,6 +50,8 @@ package_python2-miasm-git() {
optdepends=('python2-llvmlite: jit with LLVM engine, bridge between Miasm and LLVM IRs'
'python2-pycparser: additional features based on type manipulations'
'python2-z3: additional features based on constraint solving')
+ provides=('python2-miasm')
+ conflicts=('python2-miasm')
cd "$srcdir/$pkgbasename-py2"
python2 setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE