summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorm-pilia2018-07-10 16:17:33 +0200
committerm-pilia2018-07-10 16:17:33 +0200
commitac8c7b91977103d33ea7bfe44bb15f166be3f911 (patch)
tree78af85b3b316e60bf2903d89a700f8cc538a3e08
parentfdb09c212bab80a7ba12e2f5a03a22b81b94d825 (diff)
downloadaur-ac8c7b91977103d33ea7bfe44bb15f166be3f911.tar.gz
comments
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 144a4abcfd41..69e93e5261aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,11 +28,12 @@ done
package() {
- # NOTE
- # The official Python wheel does not wrap all image types.
- # To have them, ITK must be built from source using the
- # package insight-toolkit, enabling Python wrapping and
- # additional components to be wrapped in the CMake config.
+ # NOTE
+ # Not all image types are wrapped in the official Python wheel.
+ # If you need any type that is not included, you should build
+ # ITK from sources using the insight-toolkit package, editing
+ # the PKGBUILD to enable Python wrapping and adding to the CMake
+ # confing any additional component you want to include.
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/itk"