summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorschrmh2018-09-18 07:17:58 +0200
committerschrmh2018-09-18 07:17:58 +0200
commitacd2d662eefaa4eeb50512210e475448467e99e7 (patch)
tree4931b7e827df40c1e2986afb0264c788fd135545
parent186abe359f6206a2714ce6a6d4ba122bf71548c1 (diff)
downloadaur-acd2d662eefaa4eeb50512210e475448467e99e7.tar.gz
another try
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xfakeAUR.sh11
3 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71038c5f74c7..dfe0bcf61b3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fakeaur
pkgdesc = Edit names and descriptions of AUR packages. Meme mates with nani or btwiusearch
- pkgver = r9.c1c167c
+ pkgver = r10.16df655
pkgrel = 2
url = https://github.com/schrmh/fakeAUR
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 0d99ec10fb35..f0ebef6e5ca2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hans Müller <schreibemirhalt@gmail.com>
pkgname=fakeaur
-pkgver=r9.c1c167c
+pkgver=r10.16df655
pkgrel=2
pkgdesc="Edit names and descriptions of AUR packages. Meme mates with nani or btwiusearch"
arch=('any')
diff --git a/fakeAUR.sh b/fakeAUR.sh
index d2798601ae4a..ef972a1cf188 100755
--- a/fakeAUR.sh
+++ b/fakeAUR.sh
@@ -21,6 +21,7 @@ then
exit 1
fi
+first=1
for i in "$@"
do
case $i in
@@ -93,11 +94,7 @@ for i in "$@"
echo $description
;;
*)
- preventdouble="true"
- ;;
- esac
-
- if [[ $preventdouble = "true" ]]; then
+ if [ "$first" ] then
processes=$(> >(ps -f))
pac=$(echo $processes | grep -o -P "(?<=00:00:00).*(?=$USER)" | grep -o -P "(?<=00:00:00).*(?=00:00:00)")
helper=$(echo $pac | cut -d' ' -f1)
@@ -108,6 +105,8 @@ for i in "$@"
name=$(echo ${pac} | grep -Eo "[^ ]+$")
echo ${PS1@P}$helper $1
echo -ne '\n' | eval ${pac} | sed -e "s/$name/$1/" | sed -e "s/$description/$2/"
- fi
+ fi
+ ;;
+ esac
done
exit 0