summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2015-06-08 13:48:17 -0600
committerDrew DeVault2015-06-08 13:48:17 -0600
commitacd40a2d08f9413ac16c555cc100d8434e33ccbc (patch)
tree3f42b470c4afd1ecc0055810931e9bca4d4cccc6
downloadaur-acd40a2d08f9413ac16c555cc100d8434e33ccbc.tar.gz
Initial import from aur3
-rw-r--r--.SRCINFO34
-rw-r--r--Microsoft.Portable.Common.targets4
-rw-r--r--PKGBUILD74
-rw-r--r--build_fix.patch25
-rw-r--r--mono.binfmt.d1
-rw-r--r--sgen_fix.patch112
6 files changed, 250 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07ccfe08023f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = mono-git
+ pkgdesc = Free implementation of the .NET platform including runtime and compiler
+ pkgver = 3.12.0.r8.gde2f33f
+ pkgrel = 2
+ url = http://www.mono-project.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL2.1
+ license = MPL
+ license = custom:MITX11
+ makedepends = git
+ depends = zlib
+ depends = libgdiplus>=3.8
+ depends = sh
+ depends = python
+ provides = monodoc
+ provides = mono=3.12.0
+ conflicts = monodoc
+ conflicts = mono
+ options = !makeflags
+ source = git://github.com/mono/mono.git
+ source = mono.binfmt.d
+ source = sgen_fix.patch
+ source = build_fix.patch
+ source = Microsoft.Portable.Common.targets
+ md5sums = SKIP
+ md5sums = b9ef8a65fea497acf176cca16c1e2402
+ md5sums = 8a700b94bff7a913f920e95890d2fb4c
+ md5sums = 30a5af1a4ff50b98f9e73cc2ae554115
+ md5sums = acbffadb0ac233c494b40dd5e79209a5
+
+pkgname = mono-git
+
diff --git a/Microsoft.Portable.Common.targets b/Microsoft.Portable.Common.targets
new file mode 100644
index 000000000000..82bea1e6d161
--- /dev/null
+++ b/Microsoft.Portable.Common.targets
@@ -0,0 +1,4 @@
+<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
+ <Import Project="..\Microsoft.Portable.Core.props" />
+ <Import Project="..\Microsoft.Portable.Core.targets" />
+</Project>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e12a73482fe8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# $Id: PKGBUILD 229096 2015-01-15 20:56:23Z daniel $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Brice Carpentier <brice@dlfp.org>
+
+pkgname=mono-git
+_pkgname=mono
+pkgver=3.12.0.r8.gde2f33f
+pkgrel=2
+pkgdesc="Free implementation of the .NET platform including runtime and compiler"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL2.1' 'MPL' 'custom:MITX11')
+url="http://www.mono-project.com/"
+depends=('zlib' 'libgdiplus>=3.8' 'sh' 'python')
+makedepends=('git')
+options=('!makeflags')
+provides=('monodoc' 'mono=3.12.0')
+conflicts=('monodoc' 'mono')
+source=(git://github.com/mono/mono.git
+ mono.binfmt.d
+ sgen_fix.patch
+ build_fix.patch
+ Microsoft.Portable.Common.targets)
+md5sums=('SKIP'
+ 'b9ef8a65fea497acf176cca16c1e2402'
+ '8a700b94bff7a913f920e95890d2fb4c'
+ '30a5af1a4ff50b98f9e73cc2ae554115'
+ 'acbffadb0ac233c494b40dd5e79209a5')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/mono.//;s/\.68//g'
+}
+
+build() {
+ cd "${srcdir}"/${_pkgname}
+
+ #patch -p1 < ../build_fix.patch
+ #cp ../Microsoft.Portable.Common.targets mcs/tools/xbuild/targets/
+
+ # build mono
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-quiet-build \
+ --disable-system-aot \
+ --disable-static \
+ --with-mcs-docs=no
+ make
+
+ # build jay
+ cd "${srcdir}"/${_pkgname}/mcs/jay
+ make
+}
+
+package() {
+ cd "${srcdir}"/${_pkgname}
+ make DESTDIR="${pkgdir}" install
+
+ # install jay
+ pushd "${srcdir}"/${_pkgname}/mcs/jay
+ make DESTDIR="${pkgdir}" prefix=/usr INSTALL=../../install-sh install
+ popd
+
+ # install binfmt conf file and pathes
+ install -D -m644 "${srcdir}"/mono.binfmt.d "${pkgdir}"/usr/lib/binfmt.d/mono.conf
+
+ #install license
+ mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}
+ install -m644 mcs/MIT.X11 "${pkgdir}"/usr/share/licenses/${_pkgname}/
+
+ #fix .pc file to be able to request mono on what it depends, fixes #go-oo build
+ sed -i -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
+}
diff --git a/build_fix.patch b/build_fix.patch
new file mode 100644
index 000000000000..13e864b64f95
--- /dev/null
+++ b/build_fix.patch
@@ -0,0 +1,25 @@
+From c68c72144d7b2a0516276137855d4508a3f59a17 Mon Sep 17 00:00:00 2001
+From: Michael Hutchinson <m.j.hutchinson@gmail.com>
+Date: Tue, 1 Apr 2014 17:21:51 -0400
+Subject: [PATCH] [xbuild] Include PCL common targets in tarball
+
+BXC18690 - Microsoft.Portable.Common.targets is missing in mono 3.4.0 tarball
+---
+ mcs/tools/xbuild/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/mcs/tools/xbuild/Makefile b/mcs/tools/xbuild/Makefile
+index c3a5d6a..31d5329 100644
+--- a/mcs/tools/xbuild/Makefile
++++ b/mcs/tools/xbuild/Makefile
+@@ -93,6 +93,7 @@ EXTRA_DISTFILES = \
+ frameworks/net_4.5.xml \
+ targets/Microsoft.Portable.CSharp_4.0.targets \
+ targets/Microsoft.Portable.CSharp_4.5.targets \
++ targets/Microsoft.Portable.Common.targets \
+ targets/Microsoft.Portable.Core.targets \
+ targets/Microsoft.Portable.Core.props \
+ targets/Microsoft.WebApplication.targets \
+--
+1.9.3
+
diff --git a/mono.binfmt.d b/mono.binfmt.d
new file mode 100644
index 000000000000..3075b0dc5e4e
--- /dev/null
+++ b/mono.binfmt.d
@@ -0,0 +1 @@
+:CLR:M::MZ::/usr/bin/mono:
diff --git a/sgen_fix.patch b/sgen_fix.patch
new file mode 100644
index 000000000000..40cb9fba7faf
--- /dev/null
+++ b/sgen_fix.patch
@@ -0,0 +1,112 @@
+From d2cc22580898df5d4a15e0f99ab513e1570a6082 Mon Sep 17 00:00:00 2001
+From: Zoltan Varga <vargaz@gmail.com>
+Date: Fri, 20 Sep 2013 19:06:34 +0200
+Subject: [PATCH] [sgen] Use __builtin_ctzl () in OBJ_BITMAP_FOREACH_PTR () on
+ 64 bit platforms. Fixes #14834.
+
+---
+ mono/metadata/sgen-descriptor.h | 28 +++++++++++++++++++++++++---
+ mono/tests/sgen-descriptors.cs | 15 +++++++++++++--
+ 2 files changed, 38 insertions(+), 5 deletions(-)
+
+diff --git a/mono/metadata/sgen-descriptor.h b/mono/metadata/sgen-descriptor.h
+index cd53a86..3a00589 100644
+--- a/mono/metadata/sgen-descriptor.h
++++ b/mono/metadata/sgen-descriptor.h
+@@ -170,21 +170,43 @@ enum {
+ } \
+ } while (0)
+
+-#ifdef __GNUC__
++#if defined(__GNUC__) && SIZEOF_VOID_P==4
++#define OBJ_BITMAP_FOREACH_PTR(desc,obj) do { \
++ /* there are pointers */ \
++ void **_objptr = (void**)(obj); \
++ gsize _bmap = (desc) >> 16; \
++ _objptr += OBJECT_HEADER_WORDS; \
++ { \
++ int _index = __builtin_ctz (_bmap); \
++ _objptr += _index; \
++ _bmap >>= (_index + 1); \
++ HANDLE_PTR (_objptr, (obj)); \
++ _objptr ++; \
++ } \
++ while (_bmap) { \
++ int _index = __builtin_ctz (_bmap); \
++ _objptr += _index; \
++ _bmap >>= (_index + 1); \
++ HANDLE_PTR (_objptr, (obj)); \
++ _objptr ++; \
++ } \
++ } while (0)
++#elif defined(__GNUC__) && SIZEOF_VOID_P==8
++/* Same as above, but use _builtin_ctzl () */
+ #define OBJ_BITMAP_FOREACH_PTR(desc,obj) do { \
+ /* there are pointers */ \
+ void **_objptr = (void**)(obj); \
+ gsize _bmap = (desc) >> 16; \
+ _objptr += OBJECT_HEADER_WORDS; \
+ { \
+- int _index = __builtin_ctz (_bmap); \
++ int _index = __builtin_ctzl (_bmap); \
+ _objptr += _index; \
+ _bmap >>= (_index + 1); \
+ HANDLE_PTR (_objptr, (obj)); \
+ _objptr ++; \
+ } \
+ while (_bmap) { \
+- int _index = __builtin_ctz (_bmap); \
++ int _index = __builtin_ctzl (_bmap); \
+ _objptr += _index; \
+ _bmap >>= (_index + 1); \
+ HANDLE_PTR (_objptr, (obj)); \
+diff --git a/mono/tests/sgen-descriptors.cs b/mono/tests/sgen-descriptors.cs
+index ae00084..246e5aa 100644
+--- a/mono/tests/sgen-descriptors.cs
++++ b/mono/tests/sgen-descriptors.cs
+@@ -1,4 +1,5 @@
+ using System;
++using System.Runtime.InteropServices;
+
+ public struct SmallMixed
+ {
+@@ -47,6 +48,13 @@ public class HugePtrFree {
+ public LargeStruct2 c;
+ }
+
++[StructLayout (LayoutKind.Sequential)]
++public class Non32bitBitmap {
++ public object o;
++ public long i1, i2, i3, i4, i5, i6, i7, i8, i9, i10, i11, i12, i13, i14, i15, i16, i17, i18, i19, i20, i21, i22, i23, i24, i25, i26, i27, i28, i29, i30, i31, i32, i33, i34, i35;
++ public object o2;
++}
++
+ /*
+ This is a stress test for descriptors.
+ */
+@@ -54,10 +62,10 @@ class Driver {
+ static char[] FOO = new char[] { 'f', 'o', 'b' };
+
+ static void Fill (int cycles) {
+- object[] root = new object [12];
++ object[] root = new object [13];
+ object[] current = root;
+ for (int i = 0; i < cycles; ++i) {
+- current [0] = new object [12];
++ current [0] = new object [13];
+ current [1] = new int [6];
+ current [2] = new int [2,3];
+ current [3] = new string (FOO);
+@@ -72,6 +80,9 @@ class Driver {
+ current [10] = new HugePtrFree ();
+ if ((i % 10000) == 0)
+ current [11] = new LargeStruct2 [1];
++
++ /* Test for 64 bit bitmap descriptors (#14834) */
++ current [12] = new Non32bitBitmap () { o = new object (), i32 = 1, i33 = 1, i34 = 1, i35 = 1, o2 = new object () };
+
+ current = (object[])current [0];
+ }
+--
+1.8.4
+