summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedroHLC2019-09-19 19:59:19 -0300
committerPedroHLC2019-09-19 19:59:19 -0300
commitad4534ab8ce309a7a8061da23288c2538fef52cd (patch)
treee109634ac7c7fdc7bffd146a3fff773ff8cd3d67
downloadaur-ad4534ab8ce309a7a8061da23288c2538fef52cd.tar.gz
Init release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba14f55e06e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bluespec
+ pkgdesc = Bluespec SystemVerilog Tools
+ pkgver = 2019.05.beta2
+ pkgrel = 0
+ url = http://forum.bluespec.com
+ arch = x86_64
+ license = custom
+ depends = glibc
+ depends = libstdc++5
+ depends = gmp4
+ optdepends = emacs: Syntax highlight with emacs
+ optdepends = vim: Syntax highlight with vim
+ options = !strip
+ source = https://s3.wasabisys.com/bluespec/downloads/Bluespec-2019.05.beta2/Bluespec-2019.05.beta2-centos7-amd64.tar.gz
+ sha256sums = 99bc63f992f80d983b22f50e660a39268a997caed1f484b97161949c7ccf13e4
+
+pkgname = bluespec
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f56d19a0a27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=bluespec
+pkgver=2019.05.beta2
+pkgrel=0
+pkgdesc='Bluespec SystemVerilog Tools'
+url='http://forum.bluespec.com'
+arch=(x86_64)
+license=(custom)
+depends=(glibc libstdc++5 gmp4)
+makedepends=()
+options=(!strip)
+optdepends=(
+ 'emacs: Syntax highlight with emacs'
+ 'vim: Syntax highlight with vim'
+)
+source=('https://s3.wasabisys.com/bluespec/downloads/Bluespec-2019.05.beta2/Bluespec-2019.05.beta2-centos7-amd64.tar.gz')
+sha256sums=('99bc63f992f80d983b22f50e660a39268a997caed1f484b97161949c7ccf13e4')
+
+BUILD_DIR=build
+
+prepare() {
+ cat <<EOF > bluespec-home.sh
+export BLUESPECDIR="/opt/bluespec"
+EOF
+}
+
+package() {
+ cd "$srcdir"
+ install -d "$pkgdir/etc/profile.d"
+ install -Dm 755 ./bluespec-home.sh "$pkgdir/etc/profile.d/"
+
+ cd "Bluespec-${pkgver}-centos7-amd64"
+ install -d "$pkgdir/opt/bluespec"
+ cp -r ./lib/* "$pkgdir/opt/bluespec/"
+ install -d "$pkgdir/usr/bin"
+ install -Dm 755 ./bin/* "$pkgdir/usr/bin/"
+
+ install -d "$pkgdir/usr/share/vim/vimfiles"
+ cp -r ./util/vim/{ftdetect,indent,syntax} "$pkgdir/usr/share/vim/vimfiles/"
+} \ No newline at end of file