summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-08-07 01:12:50 +0100
committerScore_Under2023-08-07 01:12:50 +0100
commitad4aeebcea925f7a073b0b811fc045f55b8b5928 (patch)
treee7fa99ae036bfd206d6a7815e471d208ab1915eb
parent2cbf9e5c0cf7bb5c09e8703148349a20d1588bb8 (diff)
downloadaur-ad4aeebcea925f7a073b0b811fc045f55b8b5928.tar.gz
Update for v1.12.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a89112c09ab3..e6546216cc7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bandwidth
pkgdesc = Benchmark memory bandwidth
- pkgver = 1.11.2.d
+ pkgver = 1.12.2
pkgrel = 1
url = http://zsmith.co/bandwidth.php
arch = i686
@@ -9,7 +9,7 @@ pkgbase = bandwidth
makedepends = nasm
options = !makeflags
options = !debug
- source = https://zsmith.co/archives/bandwidth-1.11.2d.tar.gz
- sha256sums = ec8acd8825ca7f5bf244697bdc272edda60ca8f55ce0fa44afa9674aa21ae10f
+ source = https://zsmith.co/archives/bandwidth-1.12.2.tar.bz2
+ sha256sums = 4685a8a592f083901608f8fe72971a20893261413b9416f4f000bec66eecb8f4
pkgname = bandwidth
diff --git a/PKGBUILD b/PKGBUILD
index 929c404e2527..5bcc113b3ee4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-_orig_ver=1.11.2
-_orig_patch=d
+_orig_ver=1.12.2
+_orig_patch=
_orig_fullver=$_orig_ver$_orig_patch
pkgname=bandwidth
@@ -11,14 +11,17 @@ url="http://zsmith.co/bandwidth.php"
license=('GPL')
makedepends=('nasm')
options=(!makeflags !debug)
-sha256sums=('ec8acd8825ca7f5bf244697bdc272edda60ca8f55ce0fa44afa9674aa21ae10f')
-source=("https://zsmith.co/archives/${pkgname}-${_orig_fullver}.tar.gz")
+sha256sums=('4685a8a592f083901608f8fe72971a20893261413b9416f4f000bec66eecb8f4')
+source=("https://zsmith.co/archives/${pkgname}-${_orig_fullver}.tar.bz2")
build() {
cd "${srcdir}/${pkgname}-${_orig_fullver}"
make clean
+ # makefile uses LIB instead of LDFLAGS, and needs to know where OOC is
+ export LIB="${LDFLAGS} -L ./OOC"
+
if [ "${CARCH}" = "x86_64" ]; then
make -f Makefile-linux-x86_64 bandwidth64
else