summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiquel Lionel2021-07-10 17:33:35 +0100
committerMiquel Lionel2021-07-10 17:33:35 +0100
commitad818f1aca04a13298407ae1635106a631380b88 (patch)
tree6309bb0799158a361f5734b4e2c8655ed60b83bf
downloadaur-ad818f1aca04a13298407ae1635106a631380b88.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD66
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..047237b0de7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perl-mail-gpg
+ pkgdesc = Handling of GnuPG encrypted / signed mails
+ pkgver = 1.0.12
+ pkgrel = 1
+ url = https://metacpan.org/pod/Mail::GPG
+ arch = any
+ license = PerlArtistic
+ makedepends = perl-module-build
+ depends = perl
+ depends = perl-gnupg-interface
+ depends = perl-encode-locale
+ depends = perl-mime-tools
+ depends = perl-mailtools
+ options = !emptydirs
+ source = https://cpan.metacpan.org/authors/id/J/JR/JRED/Mail-GPG-1.0.12.tar.gz
+ md5sums = 4e18ab540a57750b1dbcbf41579a5787
+ sha256sums = a7877c9a4d61d86017606f8b25864f4df48d4c494ab343a3e712a6e9da23e6ec
+
+pkgname = perl-mail-gpg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2bcb69f980c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Generated by Xyne::Arch::CPAN 0.07
+
+pkgname=perl-mail-gpg
+pkgver=1.0.12
+pkgrel=1
+pkgdesc="Handling of GnuPG encrypted / signed mails"
+arch=('any')
+url="https://metacpan.org/pod/Mail::GPG"
+license=('PerlArtistic')
+source=("https://cpan.metacpan.org/authors/id/J/JR/JRED/Mail-GPG-$pkgver.tar.gz")
+md5sums=('4e18ab540a57750b1dbcbf41579a5787')
+sha256sums=('a7877c9a4d61d86017606f8b25864f4df48d4c494ab343a3e712a6e9da23e6ec')
+depends=('perl' 'perl-gnupg-interface' 'perl-encode-locale' 'perl-mime-tools' 'perl-mailtools')
+makedepends=('perl-module-build')
+options=(!emptydirs)
+
+build() {
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Makefile.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+
+ else
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ PERL_MM_USE_DEFAULT=1 perl Build.PL INSTALLDIRS=vendor
+ ./Build
+
+ else
+ echo "error: failed to detect build method for $pkgname"
+ echo "you may be able to fix this by editing the PKGBUILD"
+ return 1
+ fi
+ fi
+
+}
+
+package() {
+echo "pkg starts here"
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Makefile.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ make install DESTDIR="${pkgdir}"
+ else
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ ./Build install destdir=${pkgdir}
+
+ else
+ echo "error: failed to detect build method for $pkgname"
+ echo "you may be able to fix this by editing the PKGBUILD"
+ return 1
+ fi
+ fi
+
+ # remove perllocal.pod and .packlist
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}
+
+# vim:set ts=2 sw=2 et:
+
+