summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilienLIX2015-08-24 01:42:00 +0200
committerMaximilienLIX2015-08-24 01:42:00 +0200
commitadb46b0cbb1514286e11ebefcc986c3ca03acb08 (patch)
treef08aa09aca68121fd0ef4a13f40ffa2d30cc3917
downloadaur-adb46b0cbb1514286e11ebefcc986c3ca03acb08.tar.gz
#YOLO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b5cbc84a8a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = admin-git
+ pkgdesc = A cli tool to manage easly an archlinux system
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/MaximilienLIX/admin
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = sudo
+ optdepends = firefox: To manage profile and sqlite data base.
+ optdepends = grub
+ optdepends = syslinux
+ source = git+https://gitlab.com/MaximilienLIX/admin.git
+ md5sums = SKIP
+
+pkgname = admin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cc8a70bdf88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Maximilien Di Dio <mrgamerlix@gmail.com>
+
+pkgname=admin-git
+_pkgname_simple=admin
+pkgver=1.0
+pkgrel=1
+pkgdesc="A cli tool to manage easly an archlinux system"
+arch=('any')
+url="https://gitlab.com/MaximilienLIX/admin"
+license=('GPL3')
+depends=('sudo')
+optdepends=('firefox: To manage profile and sqlite data base.' 'grub' 'syslinux')
+makedepends=('git')
+source=("git+https://gitlab.com/MaximilienLIX/admin.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package()
+{
+ install -d "$pkgdir/usr/bin/"
+ install -d "$pkgdir/etc/$_pkgname_simple/"
+ install -d "$pkgdir/usr/share/man/man1/"
+
+ install -m755 "$srcdir/$_pkgname_simple/src/"{admin,admin-functions.sh} "$pkgdir/usr/bin"
+ install -m644 "$srcdir/$_pkgname_simple/conf/admin.rc" "$pkgdir/etc/$pkgname/"
+ install -m644 "$srcdir/$_pkgname_simple/doc/admin.1.gz" "$pkgdir/usr/share/man/man1/"
+}
+