summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-06-17 17:06:12 -0300
committerDaniel Bermond2023-06-17 17:06:12 -0300
commitadbcc553634788fb5534d724f7bb70cf319e06c1 (patch)
tree7e865751489283bf007321d773c6efcee8bf57e1
parent8af426c6ce8fd0bc74b7e90b03eb94de0e31456e (diff)
downloadaur-adbcc553634788fb5534d724f7bb70cf319e06c1.tar.gz
Update llvm version to match upstream
https://github.com/intel/intel-graphics-compiler/commit/ca387ba1bec9cb461fdbc8a90f5c5b5aed4ee729
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9ec96074af9..22d3da1cf8ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = intel-graphics-compiler-git
pkgdesc = Intel Graphics Compiler for OpenCL (git version)
- pkgver = 1.0.13404.r94.g98cd86ea4
+ pkgver = 1.0.14382.r126.g4b858d035
pkgrel = 1
epoch = 1
url = https://github.com/intel/intel-graphics-compiler/
@@ -20,9 +20,9 @@ pkgbase = intel-graphics-compiler-git
options = !lto
source = git+https://github.com/intel/intel-graphics-compiler.git
source = git+https://github.com/intel/vc-intrinsics.git
- source = git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_110
- source = git+https://github.com/intel/opencl-clang.git#branch=ocl-open-110
- source = git+https://github.com/llvm/llvm-project.git#tag=llvmorg-11.1.0
+ source = git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_140
+ source = git+https://github.com/intel/opencl-clang.git#branch=ocl-open-140
+ source = git+https://github.com/llvm/llvm-project.git#tag=llvmorg-14.0.5
source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#branch=main
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#branch=main
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 49b90daca490..462974b67aff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=intel-graphics-compiler-git
-pkgver=1.0.13404.r94.g98cd86ea4
-_llvmver=11
+pkgver=1.0.14382.r126.g4b858d035
+_llvmmaj=14
+_llvmver="${_llvmmaj}.0.5"
pkgrel=1
epoch=1
pkgdesc='Intel Graphics Compiler for OpenCL (git version)'
@@ -16,9 +17,9 @@ conflicts=('intel-graphics-compiler' 'intel-opencl-clang')
options=('!emptydirs' '!lto')
source=('git+https://github.com/intel/intel-graphics-compiler.git'
'git+https://github.com/intel/vc-intrinsics.git'
- "git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_${_llvmver}0"
- "git+https://github.com/intel/opencl-clang.git#branch=ocl-open-${_llvmver}0"
- "git+https://github.com/llvm/llvm-project.git#tag=llvmorg-${_llvmver}.1.0"
+ "git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_${_llvmmaj}0"
+ "git+https://github.com/intel/opencl-clang.git#branch=ocl-open-${_llvmmaj}0"
+ "git+https://github.com/llvm/llvm-project.git#tag=llvmorg-${_llvmver}"
'git+https://github.com/KhronosGroup/SPIRV-Tools.git#branch=main'
'git+https://github.com/KhronosGroup/SPIRV-Headers.git#branch=main')
sha256sums=('SKIP'
@@ -51,7 +52,7 @@ build() {
-DIGC_OPTION__ARCHITECTURE_TARGET='Linux64' \
-DIGC_OPTION__CLANG_MODE='Source' \
-DIGC_OPTION__LLD_MODE='Source' \
- -DIGC_OPTION__LLVM_PREFERRED_VERSION="${_llvmver}.1.0" \
+ -DIGC_OPTION__LLVM_PREFERRED_VERSION="${_llvmver}" \
-DIGC_OPTION__LLVM_MODE='Source' \
-DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR='OFF' \
-DIGC_OPTION__SPIRV_TOOLS_MODE='Source' \