summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatric Schmitz2015-08-12 18:44:52 +0200
committerPatric Schmitz2015-08-12 18:44:52 +0200
commitaddbc018dd1279d0d7495b4f4d60eba7119dd6b2 (patch)
tree79e483fdcf05a34a9fa821f6543e903a172f31d1
downloadaur-addbc018dd1279d0d7495b4f4d60eba7119dd6b2.tar.gz
Add initial version of synergy-1.6.3 AUR package, all 1.7 releases run very unstable on linux
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD84
-rw-r--r--missing-include-fix.patch21
-rw-r--r--synergys_at.service11
-rw-r--r--synergys_at.socket9
5 files changed, 158 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1aacdf05f6fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = synergy-1.6
+ pkgdesc = Share a single mouse and keyboard between multiple computers
+ pkgver = 1.6.3
+ pkgrel = 1
+ url = http://synergy-foss.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = libxt
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = unzip
+ depends = gcc-libs
+ depends = libxtst
+ depends = libxinerama
+ depends = libxkbcommon-x11
+ depends = avahi
+ depends = curl
+ optdepends = qt5-base: gui support
+ optdepends = openssl: encryption support
+ provides = synergy
+ conflicts = synergy
+ source = synergy::git+https://github.com/synergy/synergy.git
+ source = synergys_at.socket
+ source = synergys_at.service
+ source = missing-include-fix.patch
+ sha512sums = SKIP
+ sha512sums = f9c124533dfd0bbbb1b5036b7f4b06f7f86f69165e88b9146ff17798377119eb9f1a4666f3b2ee9840bc436558d715cdbfe2fdfd7624348fae64871f785a1a62
+ sha512sums = e85cc3452bb8ba8fcccb1857386c77eb1e4cabb149a1c492c56b38e1b121ac0e7d96c6fcbd3c9b522d3a4ae9d7a9974f4a89fc32b02a56f665be92af219e371c
+ sha512sums = 679cc88794d2ef65325ef93f1034f465824efeb2f01521eda7050556c1200df31abf9b5d055b9438d24f040c234d37b74c489e4db6acbf15a2e7fec8e1da226d
+
+pkgname = synergy-1.6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c0e9032264e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: Patric Schmitz <bzk0711@aol.com>
+# Ported from the synergy-git AUR package
+
+_pkgname=synergy
+pkgname=$_pkgname-1.6
+pkgver=1.6.3
+pkgrel=1
+pkgdesc='Share a single mouse and keyboard between multiple computers'
+url='http://synergy-foss.org'
+arch=('i686' 'x86_64')
+depends=('gcc-libs' 'libxtst' 'libxinerama' 'libxkbcommon-x11' 'avahi' 'curl')
+makedepends=('libxt' 'cmake' 'qt5-base' 'unzip')
+optdepends=(
+ 'qt5-base: gui support'
+ 'openssl: encryption support'
+)
+license=('GPL2')
+source=(
+ "$_pkgname::git+https://github.com/$_pkgname/$_pkgname.git"
+ "${_pkgname}s_at.socket"
+ "${_pkgname}s_at.service"
+ 'missing-include-fix.patch'
+)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+sha512sums=(
+ 'SKIP'
+ 'f9c124533dfd0bbbb1b5036b7f4b06f7f86f69165e88b9146ff17798377119eb9f1a4666f3b2ee9840bc436558d715cdbfe2fdfd7624348fae64871f785a1a62'
+ 'e85cc3452bb8ba8fcccb1857386c77eb1e4cabb149a1c492c56b38e1b121ac0e7d96c6fcbd3c9b522d3a4ae9d7a9974f4a89fc32b02a56f665be92af219e371c'
+ '679cc88794d2ef65325ef93f1034f465824efeb2f01521eda7050556c1200df31abf9b5d055b9438d24f040c234d37b74c489e4db6acbf15a2e7fec8e1da226d'
+)
+
+
+prepare() {
+ cd $_pkgname
+
+ git checkout 1.6.3-final
+ patch -p1 < ../missing-include-fix.patch
+
+ cd ext
+ unzip gmock-1.6.0.zip -d gmock-1.6.0
+ unzip gtest-1.6.0.zip -d gtest-1.6.0
+ unzip cryptopp562.zip -d cryptopp562
+}
+
+build() {
+ cd $_pkgname
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+
+ cd src/gui
+ qmake
+ make
+}
+
+package() {
+ # install systemd service and socket
+ install -Dm644 ${_pkgname}s_at.service "$pkgdir/usr/lib/systemd/system/${_pkgname}s@.service"
+ install -Dm644 ${_pkgname}s_at.socket "$pkgdir/usr/lib/systemd/system/${_pkgname}s@.socket"
+
+ cd $_pkgname
+
+ # install binary
+ install -Dm755 bin/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 bin/${_pkgname}c "$pkgdir/usr/bin/${_pkgname}c"
+ install -Dm755 bin/${_pkgname}d "$pkgdir/usr/bin/${_pkgname}d"
+ install -Dm755 bin/${_pkgname}s "$pkgdir/usr/bin/${_pkgname}s"
+ install -Dm755 bin/syntool "$pkgdir/usr/bin/syntool"
+ install -Dm755 bin/u$_pkgname "$pkgdir/usr/bin/u$_pkgname"
+
+ # install config
+ install -Dm644 doc/$_pkgname.conf.example "$pkgdir/etc/$_pkgname.conf.example"
+ install -Dm644 doc/$_pkgname.conf.example-advanced "$pkgdir/etc/$_pkgname.conf.example-advanced"
+ install -Dm644 doc/$_pkgname.conf.example-basic "$pkgdir/etc/$_pkgname.conf.example-basic"
+
+ # install manfiles
+ install -Dm644 doc/${_pkgname}c.man "$pkgdir/usr/share/man/man1/${_pkgname}c.1"
+ install -Dm644 doc/${_pkgname}s.man "$pkgdir/usr/share/man/man1/${_pkgname}s.1"
+
+ # install desktop/icon stuff
+ install -Dm644 res/$_pkgname.ico "$pkgdir/usr/share/icons/$_pkgname.ico"
+ install -Dm644 res/$_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}
diff --git a/missing-include-fix.patch b/missing-include-fix.patch
new file mode 100644
index 000000000000..ed53bd40c927
--- /dev/null
+++ b/missing-include-fix.patch
@@ -0,0 +1,21 @@
+From 5080bf0c679711f60ca14eb5979d92f181749bb7 Mon Sep 17 00:00:00 2001
+From: Manuel Frischknecht <manuel.frischknecht@bfh.ch>
+Date: Mon, 20 Jul 2015 17:55:02 +0200
+Subject: [PATCH] Fixed a missing include that breaks the build on linux
+
+---
+ src/gui/src/CommandProcess.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/gui/src/CommandProcess.h b/src/gui/src/CommandProcess.h
+index 62e89bf..f279dff 100644
+--- a/src/gui/src/CommandProcess.h
++++ b/src/gui/src/CommandProcess.h
+@@ -18,6 +18,7 @@
+ #ifndef COMMANDTHREAD_H
+ #define COMMANDTHREAD_H
+
++#include <QObject>
+ #include <QStringList>
+
+ class CommandProcess : public QObject
diff --git a/synergys_at.service b/synergys_at.service
new file mode 100644
index 000000000000..813fd6bd2c0e
--- /dev/null
+++ b/synergys_at.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Synergy Server Daemon
+After=network.target
+
+[Service]
+User=%i
+ExecStart=/usr/bin/synergys --no-daemon --config /etc/synergy.conf
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/synergys_at.socket b/synergys_at.socket
new file mode 100644
index 000000000000..9ab4bca7d852
--- /dev/null
+++ b/synergys_at.socket
@@ -0,0 +1,9 @@
+[Unit]
+Conflicts=synergys@.service
+
+[Socket]
+ListenStream=24800
+Accept=false
+
+[Install]
+WantedBy=sockets.target