summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAvery2023-11-12 16:47:46 +0800
committerAvery2023-11-12 16:55:25 +0800
commitade195a1e1bac652d1685e2d9bf8a94fd364cad7 (patch)
tree3d80f8de23ef0e81500ad98fce64b9e513e47507
parent2c7d0851fb34a4717772322ca9c516888fc8931a (diff)
downloadaur-ade195a1e1bac652d1685e2d9bf8a94fd364cad7.tar.gz
fix: update patches
-rw-r--r--.SRCINFO7
-rw-r--r--0000_Multi_DPI_support_via_global_factor_rescaling.patch15
-rw-r--r--PKGBUILD11
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69182b5154af..52f8d012179f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = xorg-xwayland-hidpi-xprop-git
pkgdesc = run X clients under wayland, with !733 HiDPI patch
- pkgver = 22.1.8.r260.gf490622fc
+ pkgver = 22.1.9.r400.g8252b110f
pkgrel = 1
url = https://xorg.freedesktop.org
arch = x86_64
license = custom
+ makedepends = git
makedepends = meson
makedepends = xorgproto-git
makedepends = xtrans
@@ -31,12 +32,12 @@ pkgbase = xorg-xwayland-hidpi-xprop-git
replaces = xorg-server-xwayland
options = debug
options = strip
- source = git+https://gitlab.freedesktop.org/xorg/xserver.git
+ source = git+https://anongit.freedesktop.org/git/xorg/xserver
source = 0000_Multi_DPI_support_via_global_factor_rescaling.patch::https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733.patch
source = 0001_Remove_scale_atom_access_control.patch
source = 0002_Add_unscaled_output_mode.patch
sha512sums = SKIP
- sha512sums = ab927b1e038346f967723a3d45a405a0a8339759e15901d0913a55d1348683831e0d058c76c6f7cb2e264a5cef781a507fb290d139ac0f2806a62bd20d84147d
+ sha512sums = c5011b89ea9419fe756fca403f2b7c23cf9a680fdf751dff97b5a076efd5997b0b63b777a1b542ab5c6300f4f553f7e5c264d998e7d53d568e93fc88fa8ff854
sha512sums = f16cb5455a1caf26c586cca2d1ec6f4708804721b7d6a8d8bd1e4a7b47b97e8b822d3455fce0da3c74bb14baf6a3980574d85019cf242d6a033a578587f74b14
sha512sums = 4c601d3ab5eb97d49a5bd400a6984b93b9f1f684078825a23aacbc857509cc8a11caf700bd4ba0f8320b84e9257a18db1f3d24f17907a4108d555aee02bcb71a
diff --git a/0000_Multi_DPI_support_via_global_factor_rescaling.patch b/0000_Multi_DPI_support_via_global_factor_rescaling.patch
index 6ffb3550a37a..0143ea95698b 100644
--- a/0000_Multi_DPI_support_via_global_factor_rescaling.patch
+++ b/0000_Multi_DPI_support_via_global_factor_rescaling.patch
@@ -483,7 +483,7 @@ diff --git a/hw/xwayland/xwayland-screen.c b/hw/xwayland/xwayland-screen.c
index 88192bbde..1090b6fca 100644
--- a/hw/xwayland/xwayland-screen.c
+++ b/hw/xwayland/xwayland-screen.c
-@@ -42,6 +42,8 @@
+@@ -42,10 +42,13 @@
#include <propertyst.h>
#include <inputstr.h>
#include <xserver_poll.h>
@@ -492,6 +492,11 @@ index 88192bbde..1090b6fca 100644
#include "xwayland-cursor.h"
#include "xwayland-screen.h"
+ #include "xwayland-window.h"
++#include "xwayland-window-buffers.h"
+ #include "xwayland-input.h"
+ #include "xwayland-output.h"
+ #include "xwayland-pixmap.h"
@@ -142,6 +144,55 @@ xwl_screen_get_fixed_or_first_output(struct xwl_screen *xwl_screen)
return xwl_screen_get_first_output(xwl_screen);
}
@@ -634,14 +639,6 @@ diff --git a/hw/xwayland/xwayland-screen.c b/hw/xwayland/xwayland-screen.c
index 1090b6fca..ffaeaae1a 100644
--- a/hw/xwayland/xwayland-screen.c
+++ b/hw/xwayland/xwayland-screen.c
-@@ -53,6 +53,7 @@
- #include "xwayland-pixmap.h"
- #include "xwayland-present.h"
- #include "xwayland-shm.h"
-+#include "xwayland-window-buffers.h"
-
- #ifdef MITSHM
- #include "shmint.h"
@@ -773,12 +774,23 @@ void
xwl_screen_set_global_scale(struct xwl_screen *xwl_screen, int32_t scale)
{
diff --git a/PKGBUILD b/PKGBUILD
index fb9f04ce986a..b8a7817193ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: AndyRTR <andyrtr@archlinux.org>
pkgname=xorg-xwayland-hidpi-xprop-git
-pkgver=22.1.8.r260.gf490622fc
+pkgver=22.1.9.r400.g8252b110f
pkgrel=1
arch=('x86_64')
license=('custom')
@@ -13,19 +13,20 @@ url="https://xorg.freedesktop.org"
pkgdesc="run X clients under wayland, with !733 HiDPI patch"
depends=('nettle' 'libepoxy' 'systemd-libs' 'libxfont2'
'pixman' 'xorg-server-common' 'libxcvt')
-makedepends=('meson' 'xorgproto-git' 'xtrans' 'libxkbfile' 'dbus'
+makedepends=('git' 'meson' 'xorgproto-git' 'xtrans' 'libxkbfile' 'dbus'
'xorg-font-util'
'wayland' 'wayland-protocols'
'libdrm' 'mesa-libgl'
'systemd'
'egl-wayland'
)
-source=(git+https://gitlab.freedesktop.org/xorg/xserver.git
- 0000_Multi_DPI_support_via_global_factor_rescaling.patch::https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733.patch
+# Original patch from: https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733.patch
+source=(git+https://anongit.freedesktop.org/git/xorg/xserver
+ 0000_Multi_DPI_support_via_global_factor_rescaling.patch
0001_Remove_scale_atom_access_control.patch
0002_Add_unscaled_output_mode.patch)
sha512sums=('SKIP'
- 'ab927b1e038346f967723a3d45a405a0a8339759e15901d0913a55d1348683831e0d058c76c6f7cb2e264a5cef781a507fb290d139ac0f2806a62bd20d84147d'
+ 'c5011b89ea9419fe756fca403f2b7c23cf9a680fdf751dff97b5a076efd5997b0b63b777a1b542ab5c6300f4f553f7e5c264d998e7d53d568e93fc88fa8ff854'
'f16cb5455a1caf26c586cca2d1ec6f4708804721b7d6a8d8bd1e4a7b47b97e8b822d3455fce0da3c74bb14baf6a3980574d85019cf242d6a033a578587f74b14'
'4c601d3ab5eb97d49a5bd400a6984b93b9f1f684078825a23aacbc857509cc8a11caf700bd4ba0f8320b84e9257a18db1f3d24f17907a4108d555aee02bcb71a')
provides=('xorg-server-xwayland' 'xorg-xwayland')