summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Semkin2018-09-25 03:41:22 +0300
committerIvan Semkin2018-09-25 03:41:22 +0300
commitadf649a575b676f2c5596065a675a190cab07541 (patch)
tree30c24b3f3babadd3e847dee1a266cc016a3e8529
parentf41e194b45079582095c34cdab71f0b62f09ce52 (diff)
downloadaur-adf649a575b676f2c5596065a675a190cab07541.tar.gz
Remove legacy patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--protobufHeaders.patch23
3 files changed, 6 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9d3f15d5f43..8cbf1abc176f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mir-git
pkgdesc = Canonical's display server
- pkgver = 0.32.1+465+ga1dc983fd5
- pkgrel = 2
+ pkgver = 1.0.0+8+g0b7f873aff
+ pkgrel = 1
url = https://mir-server.io
arch = x86_64
arch = i686
@@ -51,10 +51,8 @@ pkgbase = mir-git
conflicts = mir
source = git+https://github.com/MirServer/mir.git
source = https://raw.githubusercontent.com/capnproto/capnproto/04fd66e2992a3ed38d686642a3c479a7f3e131c9/c%2B%2B/cmake/FindCapnProto.cmake
- source = protobufHeaders.patch
sha256sums = SKIP
sha256sums = 83153402ea0220a9ed3f9d2c2c157eb49fedf340f368cd8173f0966b3fbf2647
- sha256sums = 88c025b35f4182fef7eed67db903e2580f69272cfaf38b7078fd571d8762a055
pkgname = mir-git
diff --git a/PKGBUILD b/PKGBUILD
index e50a9e7e0a45..ad3828dbb2ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=mir-git
_pkgname=mir
-pkgver=0.32.1+465+ga1dc983fd5
-pkgrel=2
+pkgver=1.0.0+8+g0b7f873aff
+pkgrel=1
pkgdesc="Canonical's display server"
url='https://mir-server.io'
arch=(x86_64 i686 armv7h aarch64)
@@ -19,11 +19,9 @@ optdepends=('qterminal: required for miral demos'
'xcursor-dmz: opt requirement for miral demos'
'qtubuntu: opt requirement for miral demos')
source=('git+https://github.com/MirServer/mir.git'
- 'https://raw.githubusercontent.com/capnproto/capnproto/04fd66e2992a3ed38d686642a3c479a7f3e131c9/c%2B%2B/cmake/FindCapnProto.cmake'
- 'protobufHeaders.patch')
+ 'https://raw.githubusercontent.com/capnproto/capnproto/04fd66e2992a3ed38d686642a3c479a7f3e131c9/c%2B%2B/cmake/FindCapnProto.cmake')
sha256sums=('SKIP'
- '83153402ea0220a9ed3f9d2c2c157eb49fedf340f368cd8173f0966b3fbf2647'
- '88c025b35f4182fef7eed67db903e2580f69272cfaf38b7078fd571d8762a055')
+ '83153402ea0220a9ed3f9d2c2c157eb49fedf340f368cd8173f0966b3fbf2647')
BUILD_DIR=build
@@ -32,8 +30,6 @@ prepare() {
git submodule init
git submodule update
cp ../FindCapnProto.cmake cmake/
-
- patch -Np1 -i "${srcdir}/protobufHeaders.patch"
}
pkgver() {
diff --git a/protobufHeaders.patch b/protobufHeaders.patch
deleted file mode 100644
index e2d6d222fdfe..000000000000
--- a/protobufHeaders.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From ce010778096db14de3b682313fc0376e0c8a6ada Mon Sep 17 00:00:00 2001
-From: William Wold <wm@wmww.sh>
-Date: Tue, 11 Sep 2018 14:58:04 -0700
-Subject: [PATCH] Use -std=gnu++14 instead of -std=c++14 to fix precompiled
- headers issue on Arch
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e98e309e3a..7990617e75 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -62,7 +62,7 @@ set(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "${build_types}" FORCE)
- set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "${build_types}")
-
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread -g -Werror -Wall -pedantic -Wextra -fPIC")
--set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread -g -std=c++14 -Werror -Wall -fno-strict-aliasing -pedantic -Wnon-virtual-dtor -Wextra -fPIC")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread -g -std=gnu++14 -Werror -Wall -fno-strict-aliasing -pedantic -Wnon-virtual-dtor -Wextra -fPIC")
- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--as-needed")
- set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--as-needed")
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")