summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2021-10-18 12:54:04 +0200
committerroot2021-10-18 12:54:04 +0200
commitae05ef4d7ef3b109fb1ab2906a0066b7f029b0d1 (patch)
tree1932bde47b7b51bc6b11d3a920fe2e5dbb844e2d
parente9d2d42e7d7e3f4b4b90bc06073932d1d008caf3 (diff)
downloadaur-ae05ef4d7ef3b109fb1ab2906a0066b7f029b0d1.tar.gz
PKGBUILD optical and slight functional improvements.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD38
2 files changed, 29 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8e9e934630f..10f090637849 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = wammu
pkgdesc = A wxPython-based GUI for Gammu
pkgver = 0.44
- pkgrel = 5
+ pkgrel = 6
url = https://wammu.eu/wammu/
arch = any
license = GPL
makedepends = python2-setuptools
depends = python2-gammu
- depends = wxpython
depends = python2-six
+ depends = wxpython
optdepends = gnome-bluetooth: Bluetooth support
optdepends = python2-pybluez: Bluetooth support
source = https://dl.cihar.com/wammu/v0/wammu-0.44.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 43c75449fb37..e66e6b2da18b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,44 @@
# Maintainer: dreieck
# Contributor: Gasparotto Mattia <gasmat04@gmail.com>
+### Note on python version for wammu 0.44: Python2.
+
pkgname=wammu
pkgver=0.44
-pkgrel=5
+pkgrel=6
pkgdesc="A wxPython-based GUI for Gammu"
arch=('any')
url="https://wammu.eu/wammu/"
license=('GPL')
-depends=('python2-gammu' 'wxpython' 'python2-six')
-makedepends=('python2-setuptools')
-optdepends=('gnome-bluetooth: Bluetooth support'
- 'python2-pybluez: Bluetooth support')
-source=(https://dl.cihar.com/$pkgname/v0/$pkgname-$pkgver.tar.xz)
-sha256sums=('bf8199f888cb60e4a24839e71ec6f8e8deb11fd22f592fe1112e3252bd4b9145')
-
+depends=(
+ 'python2-gammu'
+ 'python2-six'
+ 'wxpython'
+)
+makedepends=(
+ 'python2-setuptools'
+)
+optdepends=(
+ 'gnome-bluetooth: Bluetooth support'
+ 'python2-pybluez: Bluetooth support'
+)
+source=(
+ "https://dl.cihar.com/${pkgname}/v0/${pkgname}-${pkgver}.tar.xz"
+)
+sha256sums=(
+ 'bf8199f888cb60e4a24839e71ec6f8e8deb11fd22f592fe1112e3252bd4b9145'
+)
prepare() {
- cd "$pkgname-$pkgver"
- sed -i 's_/usr/bin/env python_/usr/bin/env python2_' setup.py
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ for _pyfile in *.py; do
+ msg "Patching shabeng line for python 2 in '${_pyfile}' ..."
+ sed -E -i '1s|^#!(.*)python$|#!\1python2|' "${_pyfile}"
+ done
}
package() {
- cd "$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
}