summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteljay2018-11-27 22:48:30 +0100
committerMatteljay2018-11-27 22:48:30 +0100
commitae13965b44cf5a6d9b438ebf506e62ef5f6a6452 (patch)
tree12780151a0c1aee63a806c4f8b6432054e469c45
downloadaur-ae13965b44cf5a6d9b438ebf506e62ef5f6a6452.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3dbc609c674e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = labelpush
+ pkgdesc = Simple lightweight label printing app
+ pkgver = 2018.11.27
+ pkgrel = 1
+ url = https://github.com/Matteljay/labelpush
+ arch = any
+ license = MIT
+ depends = python-kivy
+ depends = python-pillow
+ depends = cups
+ source = labelpush-2018.11.27.tar.gz::https://github.com/Matteljay/labelpush/archive/2018.11.27.tar.gz
+ sha256sums = 8db86374490d002ee7934e7cae10c0be8d8327a53b8c3a05cfcaf2294bf7c6e9
+
+pkgname = labelpush
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95a2a1360df7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Matteljay <matteljay at pm dot me>
+pkgname=labelpush
+pkgver=2018.11.27
+pkgrel=1
+pkgdesc='Simple lightweight label printing app'
+arch=('any')
+url="https://github.com/Matteljay/$pkgname"
+license=('MIT')
+depends=('python-kivy' 'python-pillow' 'cups')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Matteljay/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('8db86374490d002ee7934e7cae10c0be8d8327a53b8c3a05cfcaf2294bf7c6e9')
+
+package() {
+ cd $pkgname-$pkgver
+ mkdir -vp $pkgdir/usr/bin/ $pkgdir/usr/share/
+ cp -vf $pkgname.py $pkgdir/usr/bin/
+ cp -vrf data/* $pkgdir/usr/share/
+}
+
+# End of file
+
+
+
+