summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonard de Ruijter2017-09-25 06:10:55 +0200
committerLeonard de Ruijter2017-09-25 06:10:55 +0200
commitae30f56c74c483922a9b01211612a68d84c4fbf0 (patch)
treef5d5cf813f67a822a74b2e5bde9a7050b00160d1
parentc5a0961bf5da76f90ed80170eabb26617d872116 (diff)
downloadaur-ae30f56c74c483922a9b01211612a68d84c4fbf0.tar.gz
Add a patch for ssl provided by upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--fixssl.patch35
3 files changed, 44 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1102d12d04ee..a308124d8c06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Sep 23 16:49:55 UTC 2017
+# Mon Sep 25 04:10:45 UTC 2017
pkgbase = icecast-kh
pkgdesc = The KH branche extends the official release of Icecast with features that may be (if found to be working out well) merged into the next official release.
pkgver = 2.4.0_kh6
- pkgrel = 2
+ pkgrel = 3
url = http://karlheyes.github.com
install = icecast-kh.install
arch = i686
@@ -25,10 +25,12 @@ pkgbase = icecast-kh
source = https://github.com/karlheyes/icecast-kh/archive/icecast-2.4.0-kh6.tar.gz
source = icecast-kh.logrotate
source = start-by-icecast.patch
+ source = fixssl.patch
source = icecast-kh.service
sha256sums = 53f842c7ed41004a853a3d6b814878663c601b321058298e7d68c3f8b6055f16
sha256sums = 46f4d6942223a6d82f0b188e616a8a9cda3911663d59cc976c44b7a9822149f0
sha256sums = b09ac79daccf8347ead4088aca31d2214dcd27e211e9ee2e96ef1a44b65df84f
+ sha256sums = 71880af596141b4f4d3766b7336bb40deffbd34d546fb3d3675f99f3ac84cccd
sha256sums = 4b7f31aff45c6a572d54279531b7944567363d4c2bcd86d9c48887dc7da80a73
pkgname = icecast-kh
diff --git a/PKGBUILD b/PKGBUILD
index 8cc85677c925..21efa0b64179 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=icecast-kh
pkgver=2.4.0_kh6
-pkgrel=2
+pkgrel=3
pkgdesc='The KH branche extends the official release of Icecast with features that may be (if found to be working out well) merged into the next official release.'
arch=('i686' 'x86_64')
url='http://karlheyes.github.com'
@@ -17,17 +17,20 @@ install=$pkgname.install
source=(https://github.com/karlheyes/$pkgname/archive/${pkgname/-*}-${pkgver//_/-}.tar.gz
$pkgname.logrotate
start-by-icecast.patch
+fixssl.patch
$pkgname.service)
sha256sums=('53f842c7ed41004a853a3d6b814878663c601b321058298e7d68c3f8b6055f16'
'46f4d6942223a6d82f0b188e616a8a9cda3911663d59cc976c44b7a9822149f0'
'b09ac79daccf8347ead4088aca31d2214dcd27e211e9ee2e96ef1a44b65df84f'
+ '71880af596141b4f4d3766b7336bb40deffbd34d546fb3d3675f99f3ac84cccd'
'4b7f31aff45c6a572d54279531b7944567363d4c2bcd86d9c48887dc7da80a73')
_srcpath=$pkgname-${pkgname/-*}-${pkgver//_/-}
build() {
cd "$srcdir/$_srcpath"
patch -Np1 -i "${srcdir}/start-by-icecast.patch"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-openssl=/usr/bin/openssl
+ patch -Np1 -i "${srcdir}/fixssl.patch"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
diff --git a/fixssl.patch b/fixssl.patch
new file mode 100644
index 000000000000..bc3c3f9387ac
--- /dev/null
+++ b/fixssl.patch
@@ -0,0 +1,35 @@
+diff --git a/src/connection.c b/src/connection.c
+index 9af06b2..157556c 100644
+--- a/src/connection.c
++++ b/src/connection.c
+@@ -84,16 +84,25 @@ static DH *get_dh2048()
+ 0x02,
+ };
+ DH *dh;
++ BIGNUM *p, *g;
+
+- if ((dh=DH_new()) == NULL) return NULL;
+- dh->p = BN_bin2bn (dh2048_p, sizeof(dh2048_p), NULL);
+- dh->g = BN_bin2bn (dh2048_g, sizeof(dh2048_g), NULL);
+- if ((dh->p == NULL) || (dh->g == NULL))
++ if ((dh=DH_new()) == NULL) return NULL;
++ p = BN_bin2bn (dh2048_p, sizeof(dh2048_p), NULL);
++ g = BN_bin2bn (dh2048_g, sizeof(dh2048_g), NULL);
++ if ((p == NULL) || (g == NULL))
+ {
++ BN_free (p);
++ BN_free (g);
+ DH_free (dh);
+ return NULL;
+ }
+- return dh;
++#if OPENSSL_VERSION_NUMBER >= 0x10100005L
++ DH_set0_pqg(dh, p, NULL, g);
++#else
++ dh->p = p;
++ dh->g = g;
++#endif
++ return dh;
+ }
+ #endif
+ #endif // END DH CODE