summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraimileus2018-01-24 19:34:28 +0100
committeraimileus2018-01-24 19:34:55 +0100
commitae35244ff0f49af38905512a199023f907849e8b (patch)
tree81ad796b339929d67cb69d6d43615a642237b976
downloadaur-ae35244ff0f49af38905512a199023f907849e8b.tar.gz
python-snowboy-git - initial release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97240045277c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-snowboy-git
+ pkgdesc = A hotword detection engine - Python bindings
+ pkgver = v1.2.0.r128.g4ee4811
+ pkgrel = 1
+ url = https://snowboy.kitt.ai/
+ arch = x86_64
+ license = Apache
+ makedepends = swig
+ makedepends = python-setuptools
+ depends = python
+ depends = atlas-lapack
+ provides = python-snowboy
+ conflicts = python-snowboy
+ source = git+https://github.com/Kitt-AI/snowboy.git
+ md5sums = SKIP
+
+pkgname = python-snowboy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42251f6f2af7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: aimileus < $(echo YWltaWxpdXNAcHJvdG9ubWFpbC5jb20K | base64 -d) >
+pkgname=python-snowboy-git
+_pkgname=snowboy
+pkgver=v1.2.0.r128.g4ee4811
+pkgrel=1
+pkgdesc="A hotword detection engine - Python bindings"
+arch=('x86_64')
+url="https://snowboy.kitt.ai/"
+license=('Apache')
+depends=(
+ 'python'
+ 'atlas-lapack'
+)
+makedepends=(
+ 'swig'
+ 'python-setuptools'
+)
+conflicts=('python-snowboy')
+provides=('python-snowboy')
+source=("git+https://github.com/Kitt-AI/snowboy.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir/" --prefix=/usr
+}