summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-05-04 06:04:46 +0800
committerChocobo12018-05-04 06:07:03 +0800
commitae41e31fa4906356ae54b118c23d592c36f25f41 (patch)
treedd8decf2ead64cc3ce3e33bd4b2a6357460458e5
downloadaur-ae41e31fa4906356ae54b118c23d592c36f25f41.tar.gz
newpkg: libnfnetlink-git 1.0.1.r7.g62ca426-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b8342a5473d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libnfnetlink-git
+ pkgdesc = Low-level library for netfilter related kernel/userspace communication
+ pkgver = 1.0.1.r7.g62ca426
+ pkgrel = 1
+ url = https://netfilter.org/projects/libnfnetlink/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ provides = libnfnetlink
+ conflicts = libnfnetlink
+ source = git://git.netfilter.org/libnfnetlink
+ sha256sums = SKIP
+
+pkgname = libnfnetlink-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..340c786c7b77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libnfnetlink-git
+pkgver=1.0.1.r7.g62ca426
+pkgrel=1
+pkgdesc="Low-level library for netfilter related kernel/userspace communication"
+arch=('i686' 'x86_64')
+url="https://netfilter.org/projects/libnfnetlink/index.html"
+license=('GPL')
+depends=('glibc')
+makedepends=('git')
+provides=('libnfnetlink')
+conflicts=('libnfnetlink')
+source=("git://git.netfilter.org/libnfnetlink")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libnfnetlink"
+
+ git describe --long --tags | sed 's/^libnfnetlink-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libnfnetlink"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "libnfnetlink"
+
+ make DESTDIR="$pkgdir" install
+}