aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2023-11-11 16:44:18 +0100
committerbartus2023-11-11 16:44:18 +0100
commitae533cec118f047ccc0f6d8941befa5a34dc0cde (patch)
tree39106de0dfa835b5a28e9e0f13b1c9f1c75406b4
parente3e12e45544d4b94bca6b9be10cc8ceb50be8995 (diff)
downloadaur-ae533cec118f047ccc0f6d8941befa5a34dc0cde.tar.gz
Switch to meson after autotools was deprecated
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD55
2 files changed, 13 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3754383791a..4335a7d507e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gimp-git
pkgdesc = GNU Image Manipulation Program
- pkgver = 2.99.7.r462.d33c45fb47
+ pkgver = 2.99.17.r751.05b2f93876
pkgrel = 1
epoch = 2
url = https://www.gimp.org
@@ -9,7 +9,6 @@ pkgbase = gimp-git
license = GPL
license = LGPL
checkdepends = xorg-server-xvfb
- makedepends = vala
makedepends = git
makedepends = intltool>=0.40.1
makedepends = alsa-lib>=1.0.0
@@ -29,6 +28,7 @@ pkgbase = gimp-git
makedepends = gjs
makedepends = python-gobject
makedepends = luajit
+ makedepends = meson
depends = lcms2>=2.8
depends = libwmf>=0.2.8
depends = icu
diff --git a/PKGBUILD b/PKGBUILD
index e6a31e60a3e7..ca783102e6c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,12 @@
# Contributor: Alexander Hunziker <alex.hunziker@gmail.com>
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
-: DISABLE_MESON="${DISABLE_MESON:=1}" # switch to autotools `makepkg DISABLE_MESON=1`
-((DISABLE_MESON)) && makedepends+=('vala') || makedepends+=('meson')
-
pkgname=gimp-git
_pkgname=${pkgname%-git}
provides=(gimp)
conflicts=(gimp)
epoch=2
-pkgver=2.99.7.r462.d33c45fb47
+pkgver=2.99.17.r751.05b2f93876
pkgrel=1
pkgdesc="GNU Image Manipulation Program"
arch=('i686' 'x86_64')
@@ -45,7 +42,7 @@ makedepends+=('git' 'intltool>=0.40.1'
'alsa-lib>=1.0.0' 'libxslt' 'glib-networking'
'alsa-lib' 'curl' 'ghostscript' 'libxpm' 'webkit2gtk'
'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib'
- 'gjs' 'python-gobject' 'luajit'
+ 'gjs' 'python-gobject' 'luajit' 'meson'
)
checkdepends=('xorg-server-xvfb')
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
@@ -77,50 +74,20 @@ pkgver() {
}
build() {
- if ((DISABLE_MESON)); then
- cd $_pkgname
- ./autogen.sh \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/bin \
- --enable-mp \
- --enable-gimp-console \
- --enable-gtk-doc \
- --disable-check-update \
- --disable-python \
- --with-bug-report-url='https://github.com/bartoszek/AUR-gimp-git/issues' \
- --with-openexr \
- --without-aa
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
- else
-# export CFLAGS CXXFLAGS LDFLAGS
- meson "${srcdir}/${_pkgname}"\
- "${srcdir}/build"\
- --prefix=/usr \
- -Dbug-report-url='https://github.com/bartoszek/AUR-gimp-git/issues'
- export NINJA_STATUS="[%p | %f<%r<%u | %cbps ] "
- # shellcheck disable=SC2046 # allow MAKEFLAGS to split when passing multiple flags.
- ninja $(grep -oP -- '-+[A-z]+ ?[0-9]*'<<<"${MAKEFLAGS:--j1}") -C "${srcdir}/build"
- fi
+ meson "${srcdir}/${_pkgname}"\
+ "${srcdir}/build"\
+ --prefix=/usr \
+ -Dbug-report-url='https://github.com/bartoszek/AUR-gimp-git/issues'
+ export NINJA_STATUS="[%p | %f<%r<%u | %cbps ] "
+# shellcheck disable=SC2046 # allow MAKEFLAGS to split when passing multiple flags.
+ ninja $(grep -oP -- '-+[A-z]+ ?[0-9]*'<<<"${MAKEFLAGS:--j1}") -C "${srcdir}/build"
}
check() {
- if ((DISABLE_MESON)); then
- cd $_pkgname
- xvfb-run make check
-# xvfb-run make distcheck
- else
- ninja -C "${srcdir}/build" test
- fi
+ ninja -C "${srcdir}/build" test
}
package() {
- if ((DISABLE_MESON)); then
- cd $_pkgname
- make DESTDIR="${pkgdir}" install
- else
- DESTDIR="${pkgdir}" ninja -C "${srcdir}/build" install
- fi
+ DESTDIR="${pkgdir}" ninja -C "${srcdir}/build" install
install -Dm 644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.99/palettes/Linux.gpl"
}