summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLenny McLennington2021-12-14 13:09:08 +0000
committerLenny McLennington2021-12-14 13:09:08 +0000
commitae9343e507f1f21898855da8fdf73f4628f259a3 (patch)
treef9771fc13a78be4d7fe753f9119f861dc799ed27
parentc393aa4001d1a640b4727254757f3c7d663e3dfb (diff)
downloadaur-ae9343e507f1f21898855da8fdf73f4628f259a3.tar.gz
fix logo & rename var to be more accurate
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dd37167567c..552e55b51fe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,12 +53,12 @@ prepare() {
patch -p1 < "${srcdir}/mmc-brand.patch"
pushd ${srcdir}/MultiMC/bin
- local token_asm=$(objdump -j '.text' --no-show-raw-insn -C --disassemble='Secrets::getMSAClientID(unsigned char)' MultiMC)
- local token="$(grep -oP '[a-z0-9]{2}(?=,%r[89]d)' <<< ${token_asm} | tac | tr -d '\n')$(grep -oP '(push.+0x)\K[a-z0-9]{2}' <<< ${token_asm} | tac | tr -d '\n')"
- token="${token:0:8}-${token:8:4}-${token:12:4}-${token:16:4}-${token:20}"
+ local client_id_asm=$(objdump -j '.text' --no-show-raw-insn -C --disassemble='Secrets::getMSAClientID(unsigned char)' MultiMC)
+ local client_id="$(grep -oP '[a-z0-9]{2}(?=,%r[89]d)' <<< ${client_id_asm} | tac | tr -d '\n')$(grep -oP '(push.+0x)\K[a-z0-9]{2}' <<< ${client_id_asm} | tac | tr -d '\n')"
+ client_id="${client_id:0:8}-${client_id:8:4}-${client_id:12:4}-${client_id:16:4}-${client_id:20}"
popd
- sed -i 's/""/"'"${token}"'"/g' notsecrets/Secrets.cpp
+ sed -i 's/""/"'"${client_id}"'"/g' notsecrets/Secrets.cpp
git checkout 6a4130c9149deb029b496c81e3b874ad834c54b7 -- launcher/resources/{{OSX,flat,iOS,multimc,pe_{blue,colored,dark,light}}/scalable/multimc.svg,multimc/{32x32,128x128}/instances/infinity.png}
@@ -67,6 +67,8 @@ prepare() {
mv "$f/multimc.svg" "$f/launcher.svg"
done
+ cp launcher/resources/multimc/scalable/launcher.svg notsecrets/logo.svg
+
git submodule init
git config submodule.libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.quazip.url "${srcdir}/quazip"
@@ -95,7 +97,7 @@ check() {
package() {
cd "${srcdir}/Launcher/build"
make install DESTDIR="${pkgdir}"
- install -D "${srcdir}/Launcher/launcher/package/ubuntu/multimc/opt/multimc/icon.svg" "${pkgdir}/usr/share/pixmaps/${_pkgname}.svg"
+ install -D "${srcdir}/Launcher/launcher/resources/multimc/scalable/launcher.svg" "${pkgdir}/usr/share/pixmaps/${_pkgname}.svg"
install -D "${srcdir}/application.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -D "${srcdir}/Launcher/build/libLauncher_quazip.so" "${pkgdir}/usr/lib/libLauncher_quazip.so"
install -D "${srcdir}/Launcher/build/libLauncher_nbt++.so" "${pkgdir}/usr/lib/libLauncher_nbt++.so"