summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-08-27 22:07:07 -0400
committerTony Lambiris2018-08-27 22:07:07 -0400
commitaeb5209ec7d40b720ae5e6c6f38d485d83a3e682 (patch)
tree90ab96677f8e58a3231648ece47d28784d0b8f13
parent58c9d22f9d9110de7bf2d7e9c4db7a60bc256222 (diff)
downloadaur-aeb5209ec7d40b720ae5e6c6f38d485d83a3e682.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--arch-linux.patch16
-rw-r--r--osqueryd.service1
4 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 030dba21f2f8..6145ec8773be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 3.2.9.r6.g6b7ff81ad
+ pkgver = 3.3.0.r72.g1103d2cf2
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -55,14 +55,14 @@ pkgbase = osquery-git
options = !strip
options = !ccache
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=6b7ff81ad8041abf90d974f4025b71a24945d36a
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=1103d2cf248a04d84d93394177b197c5c579f940
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec
- sha256sums = 82611f3296d1d5b68d2cb32200c95a9ae3469dc5a9696643b69e89a5b9798a72
- sha256sums = ab8fb189578bc819d8f28bff4308613355a7641eabd7055757fcfcfd351b6043
+ sha256sums = 0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4
+ sha256sums = eb7483518e0ed6bd60445209e5aad8a69585f1d1d9f9b07bce529af8f702ce86
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index c4485ff9a9d4..e42eb9ddab38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=3.2.9.r6.g6b7ff81ad
+pkgver=3.3.0.r72.g1103d2cf2
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -20,7 +20,7 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
conflicts=()
backup=('etc/osquery/osquery.conf')
options=(!strip !ccache)
-_gitcommit='6b7ff81ad8041abf90d974f4025b71a24945d36a'
+_gitcommit='1103d2cf248a04d84d93394177b197c5c579f940'
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -28,10 +28,10 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
"arch-linux.patch")
sha256sums=('SKIP'
'ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec'
- '82611f3296d1d5b68d2cb32200c95a9ae3469dc5a9696643b69e89a5b9798a72'
- 'ab8fb189578bc819d8f28bff4308613355a7641eabd7055757fcfcfd351b6043')
+ '0c28be3fb234325c3279aa3c02a5b0636db833c06f89ec551b77addb86507ce4'
+ 'eb7483518e0ed6bd60445209e5aad8a69585f1d1d9f9b07bce529af8f702ce86')
-#pkgver() {
+##pkgver() {
# cd ${pkgname}
#
# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -65,7 +65,7 @@ build() {
export CC="/usr/bin/gcc"
export CXX="/usr/bin/g++"
- export SKIP_TESTS=True SKIP_BENCHMARKS=True
+ export SKIP_TESTS=True SKIP_BENCHMARKS=True SKIP_SMART=True
[[ -z $DEBUG ]] || unset DEBUG
cmake -Wno-dev \
@@ -75,7 +75,7 @@ build() {
-DBUILD_GMOCK=OFF \
-DCMAKE_VERBOSE_MAKEFILE=ON
- find . -type f -name link.txt -exec sed -i -re 's/Bstatic -lgflags/Bdynamic -lgflags/g' "{}" \;
+ #find . -type f -name link.txt -exec sed -i -re 's/Bstatic -lgflags/Bdynamic -lgflags/g' "{}" \;
make ${MAKEFLAGS} all
}
diff --git a/arch-linux.patch b/arch-linux.patch
index 634c914f5418..f18cd01b1410 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -54,10 +54,20 @@ index 8efb6202..7f9d64aa 100644
ADD_OSQUERY_LINK_ADDITIONAL("blkid")
ADD_OSQUERY_LINK_ADDITIONAL("ip4tc")
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1c067c938..70f98f4b7 100644
+index c7b6b23b9..57b292ee7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -327,7 +327,6 @@ if (POSIX)
+@@ -176,9 +176,6 @@ if(NOT WIN32)
+ endif()
+
+ if(POSIX)
+- add_compile_options(
+- -Werror
+- )
+ if(CLANG)
+ add_compile_options(
+ -Qunused-arguments
+@@ -330,7 +327,6 @@ if (POSIX)
# To be safe, only include them when building 'release' outputs.
add_compile_options(
"$<$<CONFIG:RELEASE>:-g>"
@@ -65,7 +75,7 @@ index 1c067c938..70f98f4b7 100644
"$<$<CONFIG:RELEASE>:-fPIE>"
"$<$<CONFIG:RELEASE>:-fpie>"
"$<$<CONFIG:RELEASE>:-fPIC>"
-@@ -546,6 +545,8 @@ endif()
+@@ -555,6 +551,8 @@ endif()
if(APPLE)
LOG_PLATFORM("OS X")
diff --git a/osqueryd.service b/osqueryd.service
index 75d04e322098..0774bee73a2f 100644
--- a/osqueryd.service
+++ b/osqueryd.service
@@ -9,7 +9,6 @@ ExecStartPre=/bin/sh -c "if [ ! -f $FLAG_FILE ]; then touch $FLAG_FILE; fi"
ExecStartPre=/bin/sh -c "if [ -f $LOCAL_PIDFILE ]; then mv $LOCAL_PIDFILE $PIDFILE; fi"
ExecStart=/usr/bin/osqueryd \
--flagfile $FLAG_FILE \
- --logger_min_stderr 1 \
--config_path $CONFIG_FILE
Restart=on-failure
KillMode=process