summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-09-30 17:21:56 -0500
committerCarlos Aznarán Laos2021-09-30 17:21:56 -0500
commitaebc1eba3a49bc4b520eeadde7fc2ba736716a56 (patch)
tree4ed20e0bfba6518b92b4130673f5170ed0f64fd0
parenta81c57010f941e4ff48be242e82ac0f4968b7727 (diff)
downloadaur-aebc1eba3a49bc4b520eeadde7fc2ba736716a56.tar.gz
Change PYTHONPYCACHEPREFIX path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5665c73e5bda..f0448cd54f5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pytest-flakes
pkgdesc = pytest plugin to check source code with pyflakes
pkgver = 4.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/asmeurer/pytest-flakes
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index a7bad991e30d..ed6bd83341fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_base=pytest-flakes
pkgname=python-${_base}
pkgver=4.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="pytest plugin to check source code with pyflakes"
arch=('any')
url="https://github.com/asmeurer/${_base}"
@@ -14,8 +14,6 @@ checkdepends=(python-coverage python-pytest-pep8)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('ca63d68063cf48789d86dee3707b3ea7c5076fc1f636e17f408ad6f444303fb3a701af8d1e464d49af745e350272bffe8596853a52c01baa0bdb0b6b0c0bb303')
-export PYTHONPYCACHEPREFIX="${BUILDDIR}/${pkgname}/.cache/cpython/"
-
build() {
cd "${_base}-${pkgver}"
python setup.py build
@@ -31,6 +29,6 @@ check() {
package() {
cd "${_base}-${pkgver}"
export PYTHONHASHSEED=0
- python setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}