summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-09 01:55:44 +0300
committerViktor Drobot2020-03-09 01:55:44 +0300
commitaebfc74d78abd5fccb5bfdb3c76b50b20fc266d6 (patch)
tree7baaf94ce5aac3cd28837ff2481cfa6a7e42b1d7
parent324432272d0cf55eab51da7a26e47bdcc49a95bd (diff)
downloadaur-aebfc74d78abd5fccb5bfdb3c76b50b20fc266d6.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9fe47a42b84..7fcf14a59391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = r-abind
- pkgdesc = Combine multidimensional arrays into a single array, a generalization of 'cbind' and 'rbind'.
+ pkgdesc = Combine Multidimensional Arrays
pkgver = 1.4.5
pkgrel = 1
url = https://cran.r-project.org/package=abind
diff --git a/PKGBUILD b/PKGBUILD
index b1023c3e850d..efbf832acdb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
-# Maintainer: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
# Contributor: Alex Branham <branham@utexas.edu>
_cranname=abind
_cranver=1.4-5
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-abind
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Combine multidimensional arrays into a single array, a generalization of 'cbind' and 'rbind'."
-arch=('any')
+pkgdesc="Combine Multidimensional Arrays"
+arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
-license=('LGPL2' 'LGPL2.1' 'LGPL3')
-depends=('r>=1.5.0' )
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+license=(LGPL2 LGPL2.1 LGPL3)
+depends=('r>=1.5.0')
+optdepends=()
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('136f981e1c4f618b64a87faaa7797c97')
-build(){
- R CMD INSTALL "${_pkgtar}" -l "$srcdir"
-}
-package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership "$_cranname" "$pkgdir"/usr/lib/R/library
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+package() {
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}