summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShengyu Zhang2019-09-25 20:12:33 +0800
committerShengyu Zhang2019-09-25 20:12:45 +0800
commitaec472110667988747452dfc61aeccab94a0e076 (patch)
tree30c6c51105a58a9c8eee194325d1e1d58ec3c284
downloadaur-aec472110667988747452dfc61aeccab94a0e076.tar.gz
addpkg: python-sphinxcontrib-golangdomain-git
Use my fork before https://bitbucket.org/ymotongpoo/sphinxcontrib-golangdomain/pull-requests/4 has been merged.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c551334b7859
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Sep 25 12:12:16 UTC 2019
+pkgbase = python-sphinxcontrib-golangdomain-git
+ pkgdesc = This is the Go-lang domain for Sphinx 1.0+.
+ pkgver = r38.85fe9cc
+ pkgrel = 1
+ url = https://bitbucket.org/SilverRainZ/sphinxcontrib-golangdomain
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-sphinx
+ provides = sphinxcontrib-golangdomain
+ conflicts = sphinxcontrib-golangdomain
+ source = sphinxcontrib-golangdomain::git+https://bitbucket.org/SilverRainZ/sphinxcontrib-golangdomain.git
+ md5sums = SKIP
+
+pkgname = python-sphinxcontrib-golangdomain-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c13669bd5023
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Shengyu Zhang <la@archlinuxcn.org>
+
+_pkgname=sphinxcontrib-golangdomain
+pkgname=python-${_pkgname}-git
+pkgver=r38.85fe9cc
+pkgrel=1
+pkgdesc='This is the Go-lang domain for Sphinx 1.0+.'
+url="https://bitbucket.org/SilverRainZ/${_pkgname}"
+arch=('any')
+license=('BSD')
+makedepends=('git' 'python-setuptools')
+depends=('python-sphinx')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: