summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-10-20 18:16:23 +0200
committerChristopher Arndt2019-10-20 18:16:23 +0200
commitaecaf0f4664e6a4e6381d3ada4af246004feaa92 (patch)
tree3eb55a6b0de0adebec4cd148b300673d2eb597d0
parent3ccc8e4dfd7c03e323c1e4e61579116d273900ce (diff)
downloadaur-aecaf0f4664e6a4e6381d3ada4af246004feaa92.tar.gz
Update pkgdesc; do not call ldconfig from waf; fix license install dir
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30977d777b64..07da6db3d872 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = suil-git
- pkgdesc = A lightweight C library for loading and wrapping LV2 plugin UIs
- pkgver = 0.10.4.r318.e067828
- pkgrel = 2
+ pkgdesc = Lightweight C library for loading and wrapping LV2 plugin UIs (git version)
+ pkgver = 0.10.4.r322.ee6ee77
+ pkgrel = 1
url = http://drobilla.net/software/suil/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 72f8f7c17a68..32c2b898b643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=suil
pkgname="${_pkgname}-git"
-pkgver=0.10.4.r318.e067828
-pkgrel=2
-pkgdesc="A lightweight C library for loading and wrapping LV2 plugin UIs"
+pkgver=0.10.4.r322.ee6ee77
+pkgrel=1
+pkgdesc="Lightweight C library for loading and wrapping LV2 plugin UIs (git version)"
arch=('i686' 'x86_64')
url="http://drobilla.net/software/suil/"
license=('custom:ISC')
@@ -31,6 +31,9 @@ prepare() {
git submodule init
git config submodule.waflib.url "${srcdir}/autowaf"
git submodule update
+
+ # remove local call to ldconfig
+ sed -i "/ldconfig/d" wscript
}
build() {
@@ -47,5 +50,5 @@ package() {
cd "${srcdir}/${_pkgname}"
python waf install --destdir="${pkgdir}"
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${_svnname}/LICENSE"
+ install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}