summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-15 23:53:43 +0100
committerNarrat2020-01-15 23:53:43 +0100
commitaed64aee056d3862783e4676cd760e06b1273668 (patch)
tree994e4d006970935f20969e18f73e12865b12ab59
parentb4d8b0795106d81cd3ba776be0493f16f638d6f6 (diff)
downloadaur-aed64aee056d3862783e4676cd760e06b1273668.tar.gz
update to 0.4.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7987888291a8..84b7fdf652f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Jul 4 17:33:16 UTC 2016
pkgbase = python-pims
pkgdesc = Python Image Sequence: Load video and sequential images
- pkgver = 0.3.3
- pkgrel = 2
+ pkgver = 0.4.1
+ pkgrel = 1
url = https://github.com/soft-matter/pims
arch = any
license = BSD
@@ -16,8 +14,8 @@ pkgbase = python-pims
depends = python-slicerator
optdepends = python-pillow: improved TIFF support
optdepends = python-tifffile: alternative TIFF support
- source = https://github.com/soft-matter/pims/archive/v0.3.3.zip
- md5sums = b0e28eece086264c979ce838d27a92e7
+ source = pims-0.4.1.tar.gz::https://github.com/soft-matter/pims/archive/v0.4.1.tar.gz
+ md5sums = b221a61c48c530d173ce37e3134da754
pkgname = python-pims
diff --git a/PKGBUILD b/PKGBUILD
index 49535d4fc084..8f3a2661f273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
-# Maintainer: Francois Boulogne <fboulogne at april dot org>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+
+_name=pims
pkgname=python-pims
-pkgver=0.3.3
-pkgrel=2
+pkgver=0.4.1
+pkgrel=1
pkgdesc="Python Image Sequence: Load video and sequential images"
url="https://github.com/soft-matter/pims"
arch=(any)
@@ -11,16 +14,21 @@ optdepends=('python-pillow: improved TIFF support'
'python-tifffile: alternative TIFF support')
makedepends=('python-setuptools' 'python-scipy' 'python-matplotlib' 'python-scikit-image')
checkdepends=('python-nose')
-source=(https://github.com/soft-matter/pims/archive/v$pkgver.zip)
+source=(${_name}-${pkgver}.tar.gz::https://github.com/soft-matter/${_name}/archive/v$pkgver.tar.gz)
+md5sums=('b221a61c48c530d173ce37e3134da754')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
check() {
- cd $srcdir/pims-"$pkgver"
+ cd "$_name-$pkgver"
nosetests3
}
package() {
- cd $srcdir/pims-"$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
-md5sums=('b0e28eece086264c979ce838d27a92e7')