summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2020-03-16 20:55:06 -0400
committerneeshy2020-04-11 15:44:36 -0400
commitaedbe5f50072c8011e07c42761f281c59a36d0d6 (patch)
tree27020987fe021509fca5a6d27e2991d924feb2f8
parent04406da1d7c074e306e0b5732efacd7a8e6f73ec (diff)
downloadaur-aedbe5f50072c8011e07c42761f281c59a36d0d6.tar.gz
miopen: half is now in the AUR
Also, remove redundant makedepends
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9518795421d3..bf9088600b2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = miopen
pkgdesc = AMD's Machine Intelligence Library
pkgver = 2.3.0.2.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ROCmSoftwarePlatform/MIOpen
arch = x86_64
license = custom:NCSAOSL
makedepends = opencl-headers
makedepends = cmake
- makedepends = hip
- makedepends = hcc
- makedepends = rocblas
+ makedepends = half
makedepends = miopengemm
depends = ocl-icd
depends = hip
@@ -18,9 +16,7 @@ pkgbase = miopen
depends = boost>=1.58
depends = clang-ocl
source = https://github.com/ROCmSoftwarePlatform/MIOpen/archive/2.2.1.tar.gz
- source = https://sourceforge.net/projects/half/files/half/2.1.0/half-2.1.0.zip
sha256sums = 445870318d7abb75a703b1021e8cb198bb64a5e1c9401487db40b5c3a7ae41e4
- sha256sums = ad1788afe0300fa2b02b0d1df128d857f021f92ccf7c8bddd07812685fa07a25
pkgname = miopen
diff --git a/PKGBUILD b/PKGBUILD
index 0c2206f7e065..8aa6cdec2d50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,15 @@ pkgname=miopen
# upstream has different versioning, let's keep it at 2.3.0 until they catch up
_pkgver=2.2.1
pkgver=2.3.0.$_pkgver
-pkgrel=2
+pkgrel=3
pkgdesc="AMD's Machine Intelligence Library"
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/MIOpen"
license=('custom:NCSAOSL')
depends=('ocl-icd' 'hip' 'hcc' 'rocblas' 'boost>=1.58' 'clang-ocl')
-makedepends=('opencl-headers' 'cmake' 'hip' 'hcc' 'rocblas' 'miopengemm')
-_halfver="2.1.0"
-source=("https://github.com/ROCmSoftwarePlatform/MIOpen/archive/$_pkgver.tar.gz"
- "https://sourceforge.net/projects/half/files/half/$_halfver/half-$_halfver.zip")
-sha256sums=('445870318d7abb75a703b1021e8cb198bb64a5e1c9401487db40b5c3a7ae41e4'
- 'ad1788afe0300fa2b02b0d1df128d857f021f92ccf7c8bddd07812685fa07a25')
+makedepends=('opencl-headers' 'cmake' 'half' 'miopengemm')
+source=("https://github.com/ROCmSoftwarePlatform/MIOpen/archive/$_pkgver.tar.gz")
+sha256sums=('445870318d7abb75a703b1021e8cb198bb64a5e1c9401487db40b5c3a7ae41e4')
build() {
mkdir -p "$srcdir/build"
@@ -28,7 +25,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/opt/rocm/miopen \
-DMIOPEN_BACKEND=HIP \
-DCMAKE_PREFIX_PATH="/opt/rocm/hcc;/opt/rocm/hip" \
- -DHALF_INCLUDE_DIR="$srcdir/include" \
+ -DHALF_INCLUDE_DIR=/usr/include/half \
"$srcdir/MIOpen-$_pkgver"
make
}