summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-28 23:56:00 +0800
committerUniversebenzene2019-08-28 23:56:00 +0800
commitaf045e070660d278083b28aba8251643d4883dde (patch)
treed52b18b5df19e857ee7edadbe3efc0b921b81f4a
downloadaur-af045e070660d278083b28aba8251643d4883dde.tar.gz
Initial import 1.6.2
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD25
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..379bba499fea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-stsci.imagestats
+ pkgdesc = STScI clipped image statistics with core functionality of IRAF's imstatistics
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://stsciimagestats.readthedocs.io/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python-numpy
+ makedepends = python-relic
+ source = https://files.pythonhosted.org/packages/source/s/stsci.imagestats/stsci.imagestats-1.6.2.tar.gz
+ source = https://raw.githubusercontent.com/spacetelescope/stsci.imagestats/master/LICENSE.txt
+ md5sums = 54fde240cb959755efee0b9f0c8e9450
+ md5sums = ca8dea23b938590a38eb415a5e448511
+
+pkgname = python-stsci.imagestats
+ depends = python>=3.5
+ depends = python-numpy>=1.13
+ optdepends = python-stsci.imagestats-doc: Documentation for STScI Imagestats
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef6375f75615
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
+LICENSE*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e989949f7079
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgbase=python-stsci.imagestats
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}")
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="STScI clipped image statistics with core functionality of IRAF's imstatistics"
+arch=('i686' 'x86_64')
+url="https://stsciimagestats.readthedocs.io/"
+license=('BSD')
+makedepends=('python-setuptools' 'python-numpy' 'python-relic')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'https://raw.githubusercontent.com/spacetelescope/stsci.imagestats/master/LICENSE.txt')
+md5sums=('54fde240cb959755efee0b9f0c8e9450'
+ 'ca8dea23b938590a38eb415a5e448511')
+
+package_python-stsci.imagestats() {
+ depends=('python>=3.5' 'python-numpy>=1.13')
+ optdepends=('python-stsci.imagestats-doc: Documentation for STScI Imagestats')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE.txt"
+ install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.rst
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}