summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2021-01-06 22:07:00 +0100
committerSefa Eyeoglu2021-01-06 22:07:00 +0100
commitaf6571e7bd49ea2a01fc0b2a4c3b8c72597207fa (patch)
tree6a7f573f633205f332e35f1284ca1b22fe615235
parentcf2e90f6e8c277748bc47c9d3cabc62217449dfb (diff)
downloadaur-af6571e7bd49ea2a01fc0b2a4c3b8c72597207fa.tar.gz
upgpkg: lightspeed-react-git r31.f396a1a-1
Backup config file
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49f7a5db1f5d..c25f285b06c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lightspeed-react-git
pkgdesc = React frontend for the Lightspeed project
- pkgver = r9.e299491
- pkgrel = 2
+ pkgver = r31.f396a1a
+ pkgrel = 1
url = https://github.com/GRVYDEV/Lightspeed-react
arch = any
license = custom:MIT
@@ -13,6 +13,7 @@ pkgbase = lightspeed-react-git
provides = lightspeed-frontend
conflicts = lightspeed-react
conflicts = lightspeed-frontend
+ backup = etc/webapps/lightspeed-react/config.json
source = lightspeed-react-git::git+https://github.com/GRVYDEV/Lightspeed-react.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 99bc642f2fa8..dbb048c5a99f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
pkgname=lightspeed-react-git
-pkgver=r9.e299491
-pkgrel=2
+pkgver=r31.f396a1a
+pkgrel=1
pkgdesc="React frontend for the Lightspeed project"
arch=(any)
url="https://github.com/GRVYDEV/Lightspeed-react"
@@ -12,6 +12,7 @@ optdepends=("nginx: Web Server to host the static web app")
makedepends=("npm" "git")
provides=("lightspeed-react" "lightspeed-frontend")
conflicts=("lightspeed-react" "lightspeed-frontend")
+backup=("etc/webapps/lightspeed-react/config.json")
source=("${pkgname}::git+https://github.com/GRVYDEV/Lightspeed-react.git")
sha512sums=('SKIP')
@@ -37,9 +38,12 @@ build() {
package() {
cd "$pkgname"
- install -d "${pkgdir}/usr/share/webapps/lightspeed-react/"
+ install -d "${pkgdir}/usr/share/webapps/lightspeed-react"
cp -r "build/." "${pkgdir}/usr/share/webapps/lightspeed-react"
+ install -Dm644 "build/config.json" "${pkgdir}/etc/webapps/lightspeed-react/config.json"
+ ln -sf "/etc/webapps/lightspeed-react/config.json" "${pkgdir}/usr/share/webapps/lightspeed-react/config.json"
+
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/lightspeed-react/README.md"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}