summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2022-11-06 15:56:38 +0100
committerLev Levitsky2022-11-06 15:56:38 +0100
commitaf6681eaee1f779c8319749d6b9d4fcd9501ec96 (patch)
tree1b215791cbbe0d8e6019ada101fb060e251226bd
parent4c26c3c1eac5bcb573a59914d0dec727ef225949 (diff)
downloadaur-af6681eaee1f779c8319749d6b9d4fcd9501ec96.tar.gz
v4.5.6
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG15
-rw-r--r--PKGBUILD4
3 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce8916bc0483..ada2c89254fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.5.5
+ pkgver = 4.5.6
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -16,7 +16,7 @@ pkgbase = python-pyteomics
optdepends = python-dill: needed for multiprocessing when pickle is not enough
optdepends = python-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.5.5-py2.py3-none-any.whl
- sha256sums = 4ac9be43cf1dec258ef2803f44c537a1fbc6c2817cbea6c2b15ec3ca6038ae70
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.5.6-py2.py3-none-any.whl
+ sha256sums = 0e279c085370e8085c84997adb8f9e16425facf2d088ba80f2b7e6bcb59cfebe
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index e5743c0cd048..b9483672c03b 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,16 @@
+4.5.6
+-----
+
+ - New function :py:func:`pyteomics.proforma.set_unimod_path` allowing the ProForma parsing machinery
+ to work with a local Unimod copy (`#85 <https://github.com/levitsky/pyteomics/pull/85>`_ by Joshua Klein).
+ See `documentation <https://pyteomics.readthedocs.io/en/latest/api/proforma.html#cv-disk-caching>`_ for a usage example.
+ - New method :py:meth:`pyteomics.proforma.Proforma.fragments` to generate m/z for an ion series
+ (`#85 <https://github.com/levitsky/pyteomics/pull/85>`_ by Joshua Klein).
+ - New function :py:func:`pyteomics.parser.to_proforma` helps convert *modX* sequences to ProForma.
+ - Fix: prevent :func:`pyteomics.mass.mass.fast_mass2` from changing `aa_mass`.
+ - Update :py:func:`pyteomics.pylab_aux.annotate_spectrum` for compatibility with latest :py:mod:`spectrum_utils`.
+ Pyteomics is now compatible with :py:mod:`spectrum_utils` 0.4.0 and newer.
+
4.5.5
-----
@@ -17,7 +30,7 @@
- Fix ThreadPool shutdown and add new parameter `ephemeral_pool` in :py:class:`pyteomics.usi.PROXIAggregator`
(`#67 <https://github.com/levitsky/pyteomics/pull/67>`_ by Joshua Klein).
- - Bugfix in `pyteomics.proforma.GenericModificationResolver` (`#68 <https://github.com/levitsky/pyteomics/issues/68>`_) by Joshua Klein.
+ - Bugfix in `pyteomics.proforma.GenericModificationResolver` (`#68 <https://github.com/levitsky/pyteomics/issues/68>`_ by Joshua Klein).
- New helper function :py:func:`pyteomics.fasta.decoy_entries`.
- New arguments `charge_carrier`, `absolute` in :py:func:`mass.calculate_mass` and
:py:meth:`mass.Composition.mass` (`#61 <https://github.com/levitsky/pyteomics/pull/61>`_).
diff --git a/PKGBUILD b/PKGBUILD
index c3121b3c3df0..51570bc1109f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=4.5.5
+pkgver=4.5.6
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('4ac9be43cf1dec258ef2803f44c537a1fbc6c2817cbea6c2b15ec3ca6038ae70')
+sha256sums=('0e279c085370e8085c84997adb8f9e16425facf2d088ba80f2b7e6bcb59cfebe')
changelog=CHANGELOG
package() {