summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort-ask2021-08-21 16:39:42 +0200
committert-ask2021-08-21 16:39:42 +0200
commitaf675e8853aaf4caa7d80c4786c32b98e7c56f6e (patch)
treea824054dc88108dd3524b62aa7ceb8737d0832e5
parent57db42bab229922e4636f9ceae1b8a25fdebef8f (diff)
downloadaur-af675e8853aaf4caa7d80c4786c32b98e7c56f6e.tar.gz
Update to version 11.2.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--substance-player11
-rw-r--r--substance-player-icon.pngbin5038 -> 0 bytes
-rw-r--r--substance-player.desktop11
5 files changed, 19 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1919566ad261..9eb0ae527b3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = substance-player
pkgdesc = PBR material preview, visualization and tweaking software.
- pkgver = 2019.2.2
+ pkgver = 11.2.1
pkgrel = 1
- url = https://www.allegorithmic.com/products/substance-player
+ url = hhttps://www.substance3d.com/
arch = x86_64
license = custom
depends = fontconfig
@@ -11,14 +11,7 @@ pkgbase = substance-player
depends = hicolor-icon-theme
depends = libtiff4
options = !strip
- source = https://download.allegorithmic.com/substance-player/2019.x/Substance_Player-2019.2.2-2644-linux-x64-standard-full.rpm
- source = substance-player-icon.png
- source = substance-player.desktop
- source = substance-player
- sha256sums = c5dbcce83185859bd4a36bd44ec7387887c676ccb14145ad4c3a0603cb1679fa
- sha256sums = 87d2e879c24a26e63334614b9f1c5d24bfb2eb2b606762b63ce5a2fe6a54345e
- sha256sums = 098fd0e11871c999b2ad2ff236d7ddc4fc857ce82ceffae3f27238a8bbcd3f15
- sha256sums = f024998986230fe480ea77c62c655e0e468e0b3664dbc0120d865311db19944e
+ source = https://download.substance3d.com/substance-player/11.x/Substance_Player-11.2.1-4934-linux-x64-standard.rpm
+ sha256sums = 3cf1c74ea0082f1e85f1b8ac293dfa660bc60f32e1c93660492b93bcfacf1339
pkgname = substance-player
-
diff --git a/PKGBUILD b/PKGBUILD
index 3b9b579ffde6..10f8ffceafc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,30 @@
-# Maintainer: Oscar Morante <spacepluk@gmail.com>
+# Maintainer: t-ask <t-ask-aur at cixera.com>
+# Co-maintainer: Oscar Morante <spacepluk@gmail.com>
# Co-maintainer: Dragoon Aethis <dragoon@dragonic.eu>
pkgname=substance-player
-pkgver=2019.2.2
-_build=2644
+pkgver=11.2.1
+_build=4934
pkgrel=1
pkgdesc="PBR material preview, visualization and tweaking software."
arch=('x86_64')
-url='https://www.allegorithmic.com/products/substance-player'
+url='hhttps://www.substance3d.com/'
license=('custom')
depends=('fontconfig' 'gcc-libs-multilib' 'glu' 'hicolor-icon-theme' 'libtiff4')
options=('!strip')
-source=("https://download.allegorithmic.com/substance-player/2019.x/Substance_Player-${pkgver}-${_build}-linux-x64-standard-full.rpm"
- 'substance-player-icon.png'
- 'substance-player.desktop'
- 'substance-player')
-sha256sums=('c5dbcce83185859bd4a36bd44ec7387887c676ccb14145ad4c3a0603cb1679fa'
- '87d2e879c24a26e63334614b9f1c5d24bfb2eb2b606762b63ce5a2fe6a54345e'
- '098fd0e11871c999b2ad2ff236d7ddc4fc857ce82ceffae3f27238a8bbcd3f15'
- 'f024998986230fe480ea77c62c655e0e468e0b3664dbc0120d865311db19944e')
+source=("https://download.substance3d.com/substance-player/11.x/Substance_Player-${pkgver}-${_build}-linux-x64-standard.rpm")
+
+sha256sums=('3cf1c74ea0082f1e85f1b8ac293dfa660bc60f32e1c93660492b93bcfacf1339')
+
validpgpkeys=()
package() {
- mkdir -p ${pkgdir}/opt/Allegorithmic
- mv ${srcdir}/opt/Allegorithmic/Substance_Player ${pkgdir}/opt/Allegorithmic
-
- install -Dm644 ${pkgdir}/opt/Allegorithmic/Substance_Player/eula.txt \
- ${pkgdir}/usr/share/licenses/${pkgname}/eula.txt
- rm ${pkgdir}/opt/Allegorithmic/Substance_Player/eula.txt
+ mkdir -p "${pkgdir}/opt/Adobe"
- # Workaround for https://forum.substance3d.com/index.php/topic,29285.0.html
- rm ${pkgdir}/opt/Allegorithmic/Substance_Player/libfreetype.so.6
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/opt/Allegorithmic/Substance_Player/resources/adobe-Substance_Player.desktop"
+ install -Dm644 "${srcdir}/opt/Allegorithmic/Substance_Player/resources/adobe-x.adobe.substance3d.designer.xml" "${pkgdir}/usr/share/mime/packages/adobe-x.adobe.substance.player.xml"
+ install -Dm644 -t "${pkgdir}/usr/share/icons" "${srcdir}/opt/Allegorithmic/Substance_Player/resources/icons/player-256x256.png"
- install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/substance-player.desktop"
- install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/substance-player-icon.png"
- install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/substance-player"
+ mv "${pkgdir}/usr/share/icons/player-256x256.png" "${pkgdir}/usr/share/icons/allegorithmic-Substance_Player.png"
+ mv "${srcdir}/opt/Allegorithmic" "${pkgdir}/opt/"
}
diff --git a/substance-player b/substance-player
deleted file mode 100644
index cd91084600a5..000000000000
--- a/substance-player
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-# If the interface is too small/big, uncomment the following line and tweak the value accordingly.
-#export QT_SCALE_FACTOR=0.75
-
-# If you're using a Nvidia Optimus setup, uncomment the line below and comment the final line to
-# always use the Nvidia GPU for this software (which is often too heavy for integrated GPUs).
-#exec primusrun /opt/Allegorithmic/Substance_Player/Substance\ Player "$@"
-
-exec /opt/Allegorithmic/Substance_Player/Substance\ Player "$@"
-
diff --git a/substance-player-icon.png b/substance-player-icon.png
deleted file mode 100644
index 97194926a997..000000000000
--- a/substance-player-icon.png
+++ /dev/null
Binary files differ
diff --git a/substance-player.desktop b/substance-player.desktop
deleted file mode 100644
index bf86c41b66e1..000000000000
--- a/substance-player.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=Substance Player
-GenericName=PBR Material Preview/Tweaking Software
-Description=PBR material preview, visualization and tweaking software
-Exec=/usr/bin/substance-player
-Icon=substance-player-icon
-Terminal=false
-Type=Application
-StartupNotify=true
-Categories=Utility;Graphics
-MimeType=application/x.allegorithmic.package;application/x.allegorithmic.substance